Trick Program Into Thinking You’re NOT Running As Admin???

Forums Operating Systems Windows Server 2008 R2 Applications Compatibility Trick Program Into Thinking You’re NOT Running As Admin???

Viewing 1 reply thread
  • Author
    Posts
    • #52179

      You can give the Microsoft Application Compatibility Toolkit a go, but u’ll have to figure out how to use it and I don’t feel like explaining it.

      http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=7352

      You might be able to force the program to run under standard user privileges by issuing the RunAsInvoker registry value, though I am not sure Windows will automate the process for you (thats what the MAC toolkit is for).

      1. Open up registry and navigate to HKEY_CURRENT_USERSoftwareMicrosoftWindows
      NTCurrentVersionAppCompatFlagsLayers

      2. Create a string value and name it the full path to your Naturally Speaking Software…

      C:Program Files (x86)DragonNaturallySpeakingNaturallySpeaking.exe (whatever it is)

      3. Double click on the newly named file and give it a value of RUNASINVOKER

      4. Refresh registry to apply changes.

      Try to run your program again and see if the same message is prompted.

      Make sure UAC is disabled as well because UAC might be forcibly causing the app to run in privileged mode.

    • #52180

      Thanks, turning off UAC was enough to fix this. I’ve never liked UAC anyway.

    • #44333

      Hello again. I have installed a program called Dragon NaturallySpeaking. it is a dictation program for microsoft office and stuff like that. It has to be installed as admin, but when just trying to run the program after install it pops a message saying “This program should not be run in Elevated mode”. Is there a way to trick it into thinking i’m running as a Standard User? I would rather not create a Standard User account just to run this one app. Thanks for any help.

Viewing 1 reply thread
  • You must be logged in to reply to this topic.