Power options greyed out

Forums Operating Systems Windows Server 2008 R2 Miscellaneous Power options greyed out

Viewing 44 reply threads
  • Author
    Posts
    • #49818

      @Indrek wrote:

      Like the title says, all the power options (including the list of power schemes from the notification area icon) are greyed out. There’s also a UAC link to “Change settings that are currently unavailable” and/or a message saying that “Some settings are managed by your system administrator”.

      I’ve looked around in Local Security Policy a little but haven’t noticed anything that might affect this. Any ideas where to look?

      Hi. Do you have any tweaking programs installed, such as TuneUp Utilities, Yamicsoft Windows 7 Manager, etc? Sometimes these programs can change your system settings and prevent you from using Windows built-in configuration settings. If not, try running Group Policy Editor (you will need to type in gpedit.msc in the run box, as this is not accessible from the Administrator Tools menu). Check out the Administrator settings in both the Computer Configuration and User Configuration sections of the editor. Take your time as there are tons of settings, but they are all categorized according to their functions. If you are unsure about how to set a setting, just select the Not Configured option and this will reset any setting you change back to its default. Good luck and I hope you are successful.

    • #59629
      AvatarAnonymous

      @Indrek wrote:

      Like the title says, all the power options (including the list of power schemes from the notification area icon) are greyed out. There’s also a UAC link to “Change settings that are currently unavailable” and/or a message saying that “Some settings are managed by your system administrator”.

      I’ve looked around in Local Security Policy a little but haven’t noticed anything that might affect this. Any ideas where to look?

      Hi. Do you have any tweaking programs installed, such as TuneUp Utilities, Yamicsoft Windows 7 Manager, etc? Sometimes these programs can change your system settings and prevent you from using Windows built-in configuration settings. If not, try running Group Policy Editor (you will need to type in gpedit.msc in the run box, as this is not accessible from the Administrator Tools menu). Check out the Administrator settings in both the Computer Configuration and User Configuration sections of the editor. Take your time as there are tons of settings, but they are all categorized according to their functions. If you are unsure about how to set a setting, just select the Not Configured option and this will reset any setting you change back to its default. Good luck and I hope you are successful.

    • #59637
      AvatarAnonymous

      Thanks for the reply. I don’t have any tweaking utilities installed.

      @moosh101 wrote:

      Check out the Administrator settings in both the Computer Configuration and User Configuration sections of the editor.

      Do you mean the Administrative Templates sections? I checked them in both Computer and User Configuration, and didn’t see anything that might affect the availability of power options. Pretty much everything there was set to “Not Configured” anyway.

      Edit: I checked all settings under both Administrative Templates sections? The only setting that’s not “Not Configured” is the one to display the shutdown event tracker (which is disabled).

    • #59630
      AvatarAnonymous

      Thanks for the reply. I don’t have any tweaking utilities installed.

      @moosh101 wrote:

      Check out the Administrator settings in both the Computer Configuration and User Configuration sections of the editor.

      Do you mean the Administrative Templates sections? I checked them in both Computer and User Configuration, and didn’t see anything that might affect the availability of power options. Pretty much everything there was set to “Not Configured” anyway.

      Edit: I checked all settings under both Administrative Templates sections? The only setting that’s not “Not Configured” is the one to display the shutdown event tracker (which is disabled).

    • #49819

      Thanks for the reply. I don’t have any tweaking utilities installed.

      @moosh101 wrote:

      Check out the Administrator settings in both the Computer Configuration and User Configuration sections of the editor.

      Do you mean the Administrative Templates sections? I checked them in both Computer and User Configuration, and didn’t see anything that might affect the availability of power options. Pretty much everything there was set to “Not Configured” anyway.

      Edit: I checked all settings under both Administrative Templates sections? The only setting that’s not “Not Configured” is the one to display the shutdown event tracker (which is disabled).

    • #49820

      Hello again,

      I assume your user account is a member of the Administrator group? Have you recently changed your account password? Also, have you tried to select a predefined power scheme in Group Policy Editor? Group Policy allows you to choose 3 options:

      1. A Custom scheme, or one that you have previously customized.
      2. High Performance.
      3. Balanced.

      You can find them in Computer Configuration-Administrative Templates-System-Power Management-Select An Active Power Plan.

      Likewise you can set User Account Control settings in Computer Configuration-Windows Settings-Security Settings-Local Policies-Security Options. You will find the UAC settings at the bottom of the list.

      I hope this helps. If not you could try asking the question on the TechNet Forum, and a Microsoft Technician might be able to offer more suggestions. Good luck 🙂

    • #59638
      AvatarAnonymous

      Hello again,

      I assume your user account is a member of the Administrator group? Have you recently changed your account password? Also, have you tried to select a predefined power scheme in Group Policy Editor? Group Policy allows you to choose 3 options:

      1. A Custom scheme, or one that you have previously customized.
      2. High Performance.
      3. Balanced.

      You can find them in Computer Configuration-Administrative Templates-System-Power Management-Select An Active Power Plan.

      Likewise you can set User Account Control settings in Computer Configuration-Windows Settings-Security Settings-Local Policies-Security Options. You will find the UAC settings at the bottom of the list.

      I hope this helps. If not you could try asking the question on the TechNet Forum, and a Microsoft Technician might be able to offer more suggestions. Good luck 🙂

    • #59631
      AvatarAnonymous

      Hello again,

      I assume your user account is a member of the Administrator group? Have you recently changed your account password? Also, have you tried to select a predefined power scheme in Group Policy Editor? Group Policy allows you to choose 3 options:

      1. A Custom scheme, or one that you have previously customized.
      2. High Performance.
      3. Balanced.

      You can find them in Computer Configuration-Administrative Templates-System-Power Management-Select An Active Power Plan.

      Likewise you can set User Account Control settings in Computer Configuration-Windows Settings-Security Settings-Local Policies-Security Options. You will find the UAC settings at the bottom of the list.

      I hope this helps. If not you could try asking the question on the TechNet Forum, and a Microsoft Technician might be able to offer more suggestions. Good luck 🙂

    • #49826

      Hello again,

      I assume your user account is a member of the Administrator group? Have you recently changed your account password? Also, have you tried to select a predefined power scheme in Group Policy Editor? Group Policy allows you to choose 3 options:

      1. A Custom scheme, or one that you have previously customized.
      2. High Performance.
      3. Balanced.

      You can find them in Computer Configuration-Administrative Templates-System-Power Management-Select An Active Power Plan.

      Likewise you can set User Account Control settings in Computer Configuration-Windows Settings-Security Settings-Local Policies-Security Options. You will find the UAC settings at the bottom of the list.

      I hope this helps. If not you could try asking the question on the TechNet Forum, and a Microsoft Technician might be able to offer more suggestions. Good luck 🙂

    • #49832

      There were a ton of group policies to browse, but as far I can see the only group policies that apply to Power Options can be found at Computer Configuration > Administrative Templates > System > Power Management. But the only thing you can do is pretty much the same thing through the GUI (turn stuff on/off, change minutes, etc). Nothing different.

      The fact that you are accessing group policy tells me that you are a member of administrators group. It’s pretty self explanatory. Administrators can change power options. Standard users cannot. If you are a member of the administrators group then we can rule out access control.

      This leaves us with two possible problems I can forsee:

      1) A corrupted user profile

      2) Outdated/incompatible display driver

      Solutions:

      First try the simplest solution. Go into user accounts, and create a temporary administrator account for example “tempadmin” and give that user administrative rights.

      Or just type in these lines in command prompt:

      net user tempadmin /add
      net user tempadmin temp
      net localgroup administrators tempadmin /add

      This will create the following:

      Username: tempadmin
      Password: temp

      Log in with newly created account and go to power options.

      This option should fix the issue if the problem was related to a corrupted user profile. If not your display driver might be giving you a problem.

      I would need to gather some information about your system so I could properly assess what resource is the culprit. With that being said, please do the following:

      1. Click on start and choose Run…
      2. Type in “msinfo32” without quotes and hit enter.
      3. At top select, Edit > Select All
      4. Click File > Save…
      5. Save the file as indreksettings.nfo

      Save the file to some location that is easy to access to “Documents” or something. After doing these tasks above, upload the NFO file to the forum here.

    • #59651
      AvatarAnonymous

      There were a ton of group policies to browse, but as far I can see the only group policies that apply to Power Options can be found at Computer Configuration > Administrative Templates > System > Power Management. But the only thing you can do is pretty much the same thing through the GUI (turn stuff on/off, change minutes, etc). Nothing different.

      The fact that you are accessing group policy tells me that you are a member of administrators group. It’s pretty self explanatory. Administrators can change power options. Standard users cannot. If you are a member of the administrators group then we can rule out access control.

      This leaves us with two possible problems I can forsee:

      1) A corrupted user profile

      2) Outdated/incompatible display driver

      Solutions:

      First try the simplest solution. Go into user accounts, and create a temporary administrator account for example “tempadmin” and give that user administrative rights.

      Or just type in these lines in command prompt:

      net user tempadmin /add
      net user tempadmin temp
      net localgroup administrators tempadmin /add

      This will create the following:

      Username: tempadmin
      Password: temp

      Log in with newly created account and go to power options.

      This option should fix the issue if the problem was related to a corrupted user profile. If not your display driver might be giving you a problem.

      I would need to gather some information about your system so I could properly assess what resource is the culprit. With that being said, please do the following:

      1. Click on start and choose Run…
      2. Type in “msinfo32” without quotes and hit enter.
      3. At top select, Edit > Select All
      4. Click File > Save…
      5. Save the file as indreksettings.nfo

      Save the file to some location that is easy to access to “Documents” or something. After doing these tasks above, upload the NFO file to the forum here.

    • #59652
      AvatarAnonymous

      Thanks for the reply. I created the new user account, but power options are still greyed out (see attached screen snip).

      System info file is also attached, as requested.
      Edit: removed attachment now.

    • #49833

      Thanks for the reply. I created the new user account, but power options are still greyed out (see attached screen snip).

      System info file is also attached, as requested.
      Edit: removed attachment now.

    • #59653
      AvatarAnonymous

      According to your system model you have a 2743A19 which is an SL400 series laptop. I didn’t see any problems with your display driver. I have an NVidia 9400 GT( close to what you got) and we got the same driver version. I typed in “power management for lenovo” and i stumbled upon a driver for your laptop. It’s called a “power management driver” it might have something to do with your mobo being able to detect certain power settings because after all it is the motherboard which is responsible for turning the hardware components on/off. Makes sense. Give it a try. Install the driver and tell me if it works.

      Download Power Management Driver

    • #49834

      According to your system model you have a 2743A19 which is an SL400 series laptop. I didn’t see any problems with your display driver. I have an NVidia 9400 GT( close to what you got) and we got the same driver version. I typed in “power management for lenovo” and i stumbled upon a driver for your laptop. It’s called a “power management driver” it might have something to do with your mobo being able to detect certain power settings because after all it is the motherboard which is responsible for turning the hardware components on/off. Makes sense. Give it a try. Install the driver and tell me if it works.

      Download Power Management Driver

    • #49835

      I installed the driver, but power options are still greyed out.

      And yes, it’s a Thinkpad SL400.

    • #59654
      AvatarAnonymous

      I installed the driver, but power options are still greyed out.

      And yes, it’s a Thinkpad SL400.

    • #49830

      1. Try resetting your power options to the default scheme.

      Open up commmand prompt and type in the following:

      powercfg -restoredefaultschemes

      2. If the above doesn’t work, try updating your 9300M to the latest version. Go to nvidia’s website and update it to the latest driver.

      Let me know if the above work or not. Also, when you installed 2K8R2 was power options ever working to begin with? I do a lot of freelance computer repair work and I cannot stress enough how important documentation is. You don’t nessecarily have to write everything down yourself. Copy and paste the documentation you found online into a word/notepad and save it! It’s certainly helped me to broaden your knowledge of computers as a whole.

    • #59635
      AvatarAnonymous

      1. Try resetting your power options to the default scheme.

      Open up commmand prompt and type in the following:

      powercfg -restoredefaultschemes

      2. If the above doesn’t work, try updating your 9300M to the latest version. Go to nvidia’s website and update it to the latest driver.

      Let me know if the above work or not. Also, when you installed 2K8R2 was power options ever working to begin with? I do a lot of freelance computer repair work and I cannot stress enough how important documentation is. You don’t nessecarily have to write everything down yourself. Copy and paste the documentation you found online into a word/notepad and save it! It’s certainly helped me to broaden your knowledge of computers as a whole.

    • #59642
      AvatarAnonymous

      1. Try resetting your power options to the default scheme.

      Open up commmand prompt and type in the following:

      powercfg -restoredefaultschemes

      2. If the above doesn’t work, try updating your 9300M to the latest version. Go to nvidia’s website and update it to the latest driver.

      Let me know if the above work or not. Also, when you installed 2K8R2 was power options ever working to begin with? I do a lot of freelance computer repair work and I cannot stress enough how important documentation is. You don’t nessecarily have to write everything down yourself. Copy and paste the documentation you found online into a word/notepad and save it! It’s certainly helped me to broaden your knowledge of computers as a whole.

    • #49824

      1. Try resetting your power options to the default scheme.

      Open up commmand prompt and type in the following:

      powercfg -restoredefaultschemes

      2. If the above doesn’t work, try updating your 9300M to the latest version. Go to nvidia’s website and update it to the latest driver.

      Let me know if the above work or not. Also, when you installed 2K8R2 was power options ever working to begin with? I do a lot of freelance computer repair work and I cannot stress enough how important documentation is. You don’t nessecarily have to write everything down yourself. Copy and paste the documentation you found online into a word/notepad and save it! It’s certainly helped me to broaden your knowledge of computers as a whole.

    • #59643
      AvatarAnonymous

      @halladayrules wrote:

      1. Try resetting your power options to the default scheme.

      Open up commmand prompt and type in the following:

      powercfg -restoredefaultschemes

      I like all of the quick commands you post, very useful! 🙂 Just like ncpa.cpl you used in some other post; never knew it existed! 😎

    • #59636
      AvatarAnonymous

      @halladayrules wrote:

      1. Try resetting your power options to the default scheme.

      Open up commmand prompt and type in the following:

      powercfg -restoredefaultschemes

      I like all of the quick commands you post, very useful! 🙂 Just like ncpa.cpl you used in some other post; never knew it existed! 😎

    • #49825
      AvatarArris
      Moderator

      @halladayrules wrote:

      1. Try resetting your power options to the default scheme.

      Open up commmand prompt and type in the following:

      powercfg -restoredefaultschemes

      I like all of the quick commands you post, very useful! 🙂 Just like ncpa.cpl you used in some other post; never knew it existed! 😎

    • #49831
      AvatarArris
      Moderator

      @halladayrules wrote:

      1. Try resetting your power options to the default scheme.

      Open up commmand prompt and type in the following:

      powercfg -restoredefaultschemes

      I like all of the quick commands you post, very useful! 🙂 Just like ncpa.cpl you used in some other post; never knew it existed! 😎

    • #49823

      I’m sorry about the 3rd one. I have been in the process of trying to migrate a motherboard with a Celeron D (not dual core lol) to a new bigger case and swapping it out for a P4 w/HT it was given to me but i think the board is bad…dang! I’ll post it in an attachment because my FTP server will probably go up and down as I am working on this.

      Try that, if it doesn’t work report back.

      Also, in c:windowssystem32

      do you see these files? I have a laptop with Server 2008 R2 standard and all of these files exists.

      powercfg.exe
      powercfg.cpl
      powercpl.dll
      powerprof.dll

    • #59641
      AvatarAnonymous

      I’m sorry about the 3rd one. I have been in the process of trying to migrate a motherboard with a Celeron D (not dual core lol) to a new bigger case and swapping it out for a P4 w/HT it was given to me but i think the board is bad…dang! I’ll post it in an attachment because my FTP server will probably go up and down as I am working on this.

      Try that, if it doesn’t work report back.

      Also, in c:windowssystem32

      do you see these files? I have a laptop with Server 2008 R2 standard and all of these files exists.

      powercfg.exe
      powercfg.cpl
      powercpl.dll
      powerprof.dll

    • #59634
      AvatarAnonymous

      I’m sorry about the 3rd one. I have been in the process of trying to migrate a motherboard with a Celeron D (not dual core lol) to a new bigger case and swapping it out for a P4 w/HT it was given to me but i think the board is bad…dang! I’ll post it in an attachment because my FTP server will probably go up and down as I am working on this.

      Try that, if it doesn’t work report back.

      Also, in c:windowssystem32

      do you see these files? I have a laptop with Server 2008 R2 standard and all of these files exists.

      powercfg.exe
      powercfg.cpl
      powercpl.dll
      powerprof.dll

    • #49829

      I’m sorry about the 3rd one. I have been in the process of trying to migrate a motherboard with a Celeron D (not dual core lol) to a new bigger case and swapping it out for a P4 w/HT it was given to me but i think the board is bad…dang! I’ll post it in an attachment because my FTP server will probably go up and down as I am working on this.

      Try that, if it doesn’t work report back.

      Also, in c:windowssystem32

      do you see these files? I have a laptop with Server 2008 R2 standard and all of these files exists.

      powercfg.exe
      powercfg.cpl
      powercpl.dll
      powerprof.dll

    • #59639
      AvatarAnonymous

      I see all those files, except the last one is called powrprof.dll (no “e” in there).

      I’m trying your ACL restore script now, will report back in a moment.

      Edit: ran the script and followed the instructions, but still no dice.

      Edit2: I also tried logging out and back in, but should I restart or something after running the script?

    • #49821

      I see all those files, except the last one is called powrprof.dll (no “e” in there).

      I’m trying your ACL restore script now, will report back in a moment.

      Edit: ran the script and followed the instructions, but still no dice.

      Edit2: I also tried logging out and back in, but should I restart or something after running the script?

    • #59632
      AvatarAnonymous

      I see all those files, except the last one is called powrprof.dll (no “e” in there).

      I’m trying your ACL restore script now, will report back in a moment.

      Edit: ran the script and followed the instructions, but still no dice.

      Edit2: I also tried logging out and back in, but should I restart or something after running the script?

    • #49827

      I see all those files, except the last one is called powrprof.dll (no “e” in there).

      I’m trying your ACL restore script now, will report back in a moment.

      Edit: ran the script and followed the instructions, but still no dice.

      Edit2: I also tried logging out and back in, but should I restart or something after running the script?

    • #59633
      AvatarAnonymous

      Extract the zip file and import the registry settings of my power options (which works) to yours.

      Restart the PC to apply changes. Report back. We are running out of options lol…

      Download Yahoo Messenger and create an account if you already don’t have a yahoo account.

      My Yahoo ID is halladayrules

    • #59640
      AvatarAnonymous

      Extract the zip file and import the registry settings of my power options (which works) to yours.

      Restart the PC to apply changes. Report back. We are running out of options lol…

      Download Yahoo Messenger and create an account if you already don’t have a yahoo account.

      My Yahoo ID is halladayrules

    • #49828

      Extract the zip file and import the registry settings of my power options (which works) to yours.

      Restart the PC to apply changes. Report back. We are running out of options lol…

      Download Yahoo Messenger and create an account if you already don’t have a yahoo account.

      My Yahoo ID is halladayrules

    • #49822

      Extract the zip file and import the registry settings of my power options (which works) to yours.

      Restart the PC to apply changes. Report back. We are running out of options lol…

      Download Yahoo Messenger and create an account if you already don’t have a yahoo account.

      My Yahoo ID is halladayrules

    • #49836

      Still nothing, power options are disabled.

      By the way, while I greatly appreciate your help, I hope you’re not going out of your way to fix this. It’s not really a major issue, I can live with just the Balanced plan; I was just wondering if there was something simple I was missing. Doesn’t look that way, so I guess we can write it off as one of the quirks of converting R2 to a workstation.

    • #59655
      AvatarAnonymous

      Still nothing, power options are disabled.

      By the way, while I greatly appreciate your help, I hope you’re not going out of your way to fix this. It’s not really a major issue, I can live with just the Balanced plan; I was just wondering if there was something simple I was missing. Doesn’t look that way, so I guess we can write it off as one of the quirks of converting R2 to a workstation.

    • #49837

      Same problem here with a Thinkpad T400. 🙁 Would be glad about any help. 🙂

    • #59656
      AvatarAnonymous

      Same problem here with a Thinkpad T400. 🙁 Would be glad about any help. 🙂

    • #49838

      The next troubleshooting tip I can think of would be to update your bios using the bios update utility found from Lenovo’s website. I’m not sure of your exact model # so you’d have to manually do that yourself. Just downloading the 64-bit version of the bios update utility. Also check in the BIOS itself to see whether or not there is an option that controls power management. If the hardware itself is being blocked from accessing power options then downloading a 3rd party software management tool will do you no good.

      Download something like this: http://www.addictivetips.com/windows-tips/windows-7-advanced-power-management/

      Does it work?

    • #59657
      AvatarAnonymous

      The next troubleshooting tip I can think of would be to update your bios using the bios update utility found from Lenovo’s website. I’m not sure of your exact model # so you’d have to manually do that yourself. Just downloading the 64-bit version of the bios update utility. Also check in the BIOS itself to see whether or not there is an option that controls power management. If the hardware itself is being blocked from accessing power options then downloading a 3rd party software management tool will do you no good.

      Download something like this: http://www.addictivetips.com/windows-tips/windows-7-advanced-power-management/

      Does it work?

    • #49839

      Just wanted to say that this is a moot issue for me as I’ve gone back to Windows 7 (shock! gasp! :P). The R2 licence will be used for a small home web/database/file server.
      Thanks for all the help anyway!

    • #59658
      AvatarAnonymous

      Just wanted to say that this is a moot issue for me as I’ve gone back to Windows 7 (shock! gasp! :P). The R2 licence will be used for a small home web/database/file server.
      Thanks for all the help anyway!

    • #43863

      Like the title says, all the power options (including the list of power schemes from the notification area icon) are greyed out. There’s also a UAC link to “Change settings that are currently unavailable” and/or a message saying that “Some settings are managed by your system administrator”.

      I’ve looked around in Local Security Policy a little but haven’t noticed anything that might affect this. Any ideas where to look?

Viewing 44 reply threads
  • You must be logged in to reply to this topic.