Logitech G15 (v2) Keyboard

Forums Operating Systems Windows Server 2008 R2 Hardware Compatibility Logitech G15 (v2) Keyboard

Viewing 6 reply threads
  • Author
    Posts
    • #43841

      Does anyone have any idea how to get the drivers for the G15 keyboard to work in 2008 R2? I keep getting a message saying that the drivers are “incompatible with this version of windows”.

      I read that people were able to get them working in the 2008 by setting the installer to vista compatibility mode. I tried this last night on my fresh install of 2008 R2 but no dice. In face I tried all of the windows xp/vista compatibility modes on both the 32 and 64 bit installer.

      Any ideas?

      Thanks,
      Vyx

    • #49640
      Arris
      Moderator

      Hello Vyx,

      Have you tried to manually unpack the installation file of the driver as explained at the Drivers page in the manual?

      Hope that works!

    • #59451
      Anonymous

      Hello Vyx,

      Have you tried to manually unpack the installation file of the driver as explained at the Drivers page in the manual?

      Hope that works!

    • #49641

      Thanks, that did the trick, I read over the website several times before I installed S2008 R2 but for some reason I didn’t remember that ><. Also, in case anyone else is wondering about this. I extracted the setup files and just ran the game panel setup. At first it wasn’t showing any of the keyboard (lcd screen) apps installed but upon restart they showed up. Vyx

    • #59452
      Anonymous

      Thanks, that did the trick, I read over the website several times before I installed S2008 R2 but for some reason I didn’t remember that ><. Also, in case anyone else is wondering about this. I extracted the setup files and just ran the game panel setup. At first it wasn’t showing any of the keyboard (lcd screen) apps installed but upon restart they showed up. Vyx

    • #49642

      You need to right click and go into Compatibility and set it to Vista SP2. It should install once you’ve done this.

    • #59453
      Anonymous

      You need to right click and go into Compatibility and set it to Vista SP2. It should install once you’ve done this.

Viewing 6 reply threads
  • You must be logged in to reply to this topic.