Creative X-Fi driver – Loud Noise and crash

Forums Operating Systems Windows Server 2008 Hardware Compatibility (New) Creative X-Fi driver – Loud Noise and crash

Viewing 17 reply threads
  • Author
    Posts
    • #43071

      I just installed Windows 2008 server and tried to install Creative X-Fi latest driver for my Creative X-Fi Elite Pro. It got loud noise (non-stop) from windows boot up. After I try to something in Creative Audio Console, my system BSOD.

      Anyone who came across this and solved this problem, please feel free to share with us over here.

    • #46092
      B1G

      hi, i have a Creative X-Fi ExtremeMusic and it’s all ok with the latest drivers

    • #46093

      Yes. I have the same Problem, and i think it’s because 4GB RAM. I had the same noise and crash with vista 64 and old drivers (before they fixed the 4GB bug under 64Bit OS).
      Anyone have an idea??

    • #46094

      Hmm, I’m running X-Fi Extreme Gamer with 4GB and haven’t had any issues at all.

    • #46095

      A new beta driver has been released.
      In release notes they write: “Resolves issue with distortion and noise occuring in systems with 4 GB of RAM or greater”.
      I tasted the driver, but i still get the loud noise and crash 🙁
      Maybe it will work with final release.

    • #46096

      Im using this beta driver (SBXF_PCDVRBETA_LB_2_14_0001) and it works flawlessly with my X-Fi Music.
      /off
      In vista/server2008 the Audio Console sets “Stereo Xpand” instead of “Stereo Surround” which i dont think is good idea so i would suggest to change it from the creative audio console.
      /off

    • #46097

      If you have 4GB of RAM in your computer and are running a 32 bit version of Server 2008 try this fix, it worked for me.

      – Start->Run->msconfig.exe
      – Boot Tab
      – Advanced Options
      – Check the maximum memory checkbox
      – Fill in 4096 as a value
      – Click OK 2x
      – Reboot the machine

    • #46098

      Awesome man, with the fix in msconfig my soundblaster works great.

    • #46099

      Oh no, with this fix i only have 3GB of RAM. This is not good. The value of 4096 is not possible.

    • #46100
      Arris
      Moderator

      Hey Bulldog,

      Sounds like you are using a x86 Windows Server 2008 OS that only detects 3GB out of the 4GB installed memory. See my reply of Why should I use a Server OS for my Workstation?? – Comment 629 how to enable PAE. Then you should have 4GB again!

    • #46101

      Probably this value limits the amount of RAM the system can take (4096 means 3gb physical ram + 1gb for drivers etc)
      You can try to increase this value to 8192, but then your probably going to experience the same problems as before.

      Arris Windows Server 2008 Enterprise x86 can detect up to 64GB of physical memory.Single application cant use more than 4GB, but the OS itself can use up to 64GB.

      The x86 processor hardware is augmented with additional address lines used to select the additional memory, so physical address size is increased from 32 bits to 36 bits. This increases maximum physical memory size from 4 GB to 64 GB. The 32-bit size of virtual address is not changed, so regular application software continues to use instructions with 32-bit addresses and (in a flat memory model) is limited to 4 gigabytes (GB). The operating system uses page tables to map this 4 GB address space onto the 64 GB of total memory, and the map is usually different for each process. In this way the extra memory is useful even though no single regular application can access it all simultaneously.

      Check out this link!

    • #46102
      Arris
      Moderator

      Oh yes I see. It also differs which version of Server 2008 x86 you are using. The Enterprise and Datacenter Editions can handle 64GB; the Standard and Webserver Editions can use 4GB. However, my experience is that using PAE is significantly slower than installing a 64bit OS. That’s one of the reasons I am using x64 now. 🙂

    • #46103

      Yeah ofcourse the performance is another issue, but the compability is an issue too – thats why im still using 2gb of faster ram 🙂

    • #46104

      I found that most of the audio problems are caused by the CMSS filter that is used by Creative’s Audio Console to upmix 2.0 > 5.1 audio content. If you dont have 2.1+ sound system you can safely disable this option.

    • #46105

      I have a X-Fi Surround USB and I have very poor Bass output with the bass-redirection activated. It’s like a vibration sound. I have yet to test it under Vista…

    • #46106

      Hey folks,
      did anyone tried the final drivers released on 30th july?
      Driver version: 2.18.0004
      I just want to know if the final drivers fix the 4gb bug with Server 2008 32bit.

      Bulldog

    • #46107
      Siv

      I had the blue screen whilst installing from the original X-Fi Fatality disk so ran the MSConfig routine that “hotdogger” recommended, I also loaded the latest Creative Drivers (2.18.0004) and all is running well and all the applications that go with the Fatality card now run fine.

      Hotdogger’s recommendation:

      If you have 4GB of RAM in your computer and are running a 32 bit version of Server 2008 try this fix, it worked for me.

      – Start->Run->msconfig.exe
      – Boot Tab
      – Advanced Options
      – Check the maximum memory checkbox
      – Fill in 4096 as a value
      – Click OK 2x
      – Reboot the machine

      Siv

    • #46108

      @hotdogger wrote:

      If you have 4GB of RAM in your computer and are running a 32 bit version of Server 2008 try this fix, it worked for me.

      – Start->Run->msconfig.exe
      – Boot Tab
      – Advanced Options
      – Check the maximum memory checkbox
      – Fill in 4096 as a value
      – Click OK 2x
      – Reboot the machine

      This fix worked for me as well.

      Thank you!

      E6600
      4GB Kingston HyperX
      P5N32-E Sli (680i)
      SB Fatal1ty

Viewing 17 reply threads
  • You must be logged in to reply to this topic.