Civilization 4 Not Running In Server 2008

Forums Operating Systems Windows Server 2008 Games Compatibility Civilization 4 Not Running In Server 2008

Viewing 2 reply threads
  • Author
    Posts
    • #46089

      Have you disabled DEP in the tutorials section on the home page?

    • #46090
      AvatarArris
      Moderator

      When you browse the internet you see several tips:
      – Install DirectX from the cd
      – Install the latest patch from http://www.2kgames.com/civ4/downloads.htm
      – Enable Direct Draw Acceleration in Start -> Run -> dxdiag -> Display tab (if not already enabled and if possible)
      – Change the fullscreen option in the config file in the installation directory to 0 (windowed)
      – Be sure you have the latest (graphic) drivers
      – Run in compatibility mode (right mouse click on the shortcut -> Properties -> Compatibility -> Run this program in compatibility mode for: -> Windows XP (Service Pack 2)

      Hope this will fix your problem! 🙂

    • #46091

      Thank you for all of your responses. I finally got it going. I upgraded the driver for my video card. It turns out that I had not updated that yet and I was just running the generic driver from Windows.

    • #43070

      Does anyone have any ideas about how to get Civilization 4 running on Server 2008. I was able to run it on Vista, but now I am having trouble. I already added the gameux.dll file and now all I get is an error with the following information.

      **Start Error**
      Initilize Renerer failed. Check DirectX Installation, Lates Graphics Drivers and Graphics Settings
      Parameters:
      -width = 1024
      -height = 768
      -flags = 0xc
      -hwnd = 0x3d0182
      -adaptrid = 0
      -deviceid = 3
      Error: Creation failed: Invalid 3D device type.
      **End Error**

      I have DirectX 10 installed. I tried the fix for Grand Theft Auto and that did not work. Please let me know if you have any ideas.

      Thanks,
      TJ

Viewing 2 reply threads
  • You must be logged in to reply to this topic.