Auto Connect to Wireless when Booting (no log in)

Forums Operating Systems Windows Server 2008 Miscellaneous Auto Connect to Wireless when Booting (no log in)

Viewing 3 reply threads
  • Author
    Posts
    • #44214

      Hi, Following advice regarding enabling wireless services on Server 2008, I have got my Netgear N300 USB wireless adapter to work fine – but only when I log into the server. I run this box remotely and need the wireless adapter to start up and connect to the wireless when the machine boots, even if I don’t log in. This is what happened with my wired LAN connection. I’ve enabled Autostart for the WLAN Autoconfig for Local System log on, also as Network Services – neither works… Any ideas would be appreciated.

    • #51666
      Arris
      Moderator

      Are you using some non-Windows wireless utility (like “Intel WIFI Connection Utility”, or in your case possibly “NETGEAR Smart Wizard”)? Those tools might start only after logging in and so no valid credentials could be provided to the wireless network.

      Just be sure you configure the key for wireless in the Windows tool and not in some third party utility. In the end it should show up in the “Manage wireless networks” page of the “Network and Sharing Center”.

      If that is configured correctly, maybe adding a startup-script with the netsh command works. This script should be added in the Local Group Policy Editor (gpedit.msc) in Computer Configuration -> Windows Settings -> Scripts (Startup/Shutdown) -> Startup. The content should be something like:

      netsh wlan connect [profilename]

      Hope you can get it working! 🙂

    • #51665

      Hello Arris – deleted Netgear Wizard from startup and configured “Manage Wireless Networks” profile and it now starts fine!

      Thanks so much for your help…

    • #51664
      Arris
      Moderator

      @mikelane wrote:

      Hello Arris – deleted Netgear Wizard from startup and configured “Manage Wireless Networks” profile and it now starts fine!

      Good to hear that and thanks for reporting back! I’m glad it works now 🙂

Viewing 3 reply threads
  • You must be logged in to reply to this topic.