Windows Store Client on server 2016

Forums Operating Systems Windows Server 2016 Wish List Progress Windows Store Client on server 2016

Viewing 5 reply threads
  • Author
    Posts
    • #45081

      I have been making attempts to get the Windows Store from Win10 working on Server 2016, but have hit a wall in getting it going. Been running the powershell commands to work with it. While I know there may be strong opinions against it, that is not the point of this. For me it’s about being able to use server 2016 as a workstation with the app store if possible (I do have a couple of essential apps I do actually use from the app store)

      This would be a wish list item. Ideally if someone else with more knowledge could get it working, or already has that would be great!

    • #61282
      Anonymous

      Ok made some progress. I was able to get the store and other default apps installed, but still not working. They do open up and immediately crash out.

      Steps to get where I got:

      1. Pulled the preloaded apps from Windows 10 WIM extracted using 7zip to get only the files from the WIM in Program FilesWindowsApps

      2.Dropped the files into C:Program FilesWindowsApps

      3. Once in that folder I ran in powershell (Run as Admin):

      Add-AppxPackage -register "C:Program FilesWindowsApps*AppXmanifest.xml" -DisableDevelopmentMode

      **Had to run step 3 5x times to make sure all of the packages installed. Apparently some depend on others and don’t install correctly the first couple of times.

      4.Then ran

      Get-AppxPackage -allusers | foreach {Add-AppxPackage -register "C:Program FilesWindowsApps*appxmanifest.xml" -DisableDevelopmentMode} 

      A this point I am stuck. The metro Apps start then immediately exit.

    • #61283
      Anonymous

      Hello atteres, I don’t know if this works because I haven’t tried it, only read it in passing on another forum and lost track — but what I read said that you could only get the Store to work on Server 2016 with a user account, not an administrative account… You may already be using a user account, and this may be a dead end. If not create one and give it a try… Generally this sort of thing comes down to versioning and/or permissions — just like my Optional Features wish list item; it’s rare that it ‘can’t be done‘, and is more typically ‘I don’t know how‘. halladayrules can probably get to the bottom of both of these in a glance, but I suspect he’s busy…

    • #61284
      Anonymous

      Unfortunately halladayrules is not active here anymore.
      Last time i heard from him he was very busy with his new job…. 😉

    • #61285
      Anonymous

      1. First for Administrator account you need :
      http://winaero.com/blog/fix-apps-and-start-menu-do-not-open-under-administrator-account-in-windows-10/

      2. After it’s possible to instal Windows Store via PowerShell :
      Required files (from Windows 10 ) :
      AppxBundle
      Microsoft.WindowsStore
      Microsoft.DesktopAppInstaller
      Microsoft.StorePurchaseApp
      Microsoft.XboxIdentityProvider
      Appx
      Microsoft.NET.Native.Framework.1.3
      Microsoft.NET.Native.Runtime.1.3
      Microsoft.VCLibs.140.00

      you also need these xml files from Licenses.zip:
      Microsoft.DesktopAppInstaller_8wekyb3d8bbwe.xml
      Microsoft.StorePurchaseApp_8wekyb3d8bbwe.xml
      Microsoft.WindowsStore_8wekyb3d8bbwe.xml
      Microsoft.XboxIdentityProvider_8wekyb3d8bbwe.xml

      =============================================================
      Notes:
      Only WindowsStore AppxBundle is mandatory,
      other three are optional but recommended to get the complete Store Apps support

      Be sure to download v1.3 of Microsoft.NET.Native.Runtime

      =============================================================

      3. Change the owner of the folder C:Program FilesWindowsApps (TrustedInstaller to Administrators) and add the following new permission to = C:Program FilesWindowsApps

      USER: ALL APPLICATION PACKAGES
      Permission: Full Access
      Be sure TrustedInstaller and System also both have FULL Access as well.
      Be sure you have permissions to inherent.

      4. After in PowerSell (Admin) :
      Add-AppxPackage -DisableDevelopmentMode -Register “C:Program FilesWindowsAppsMicrosoft.VCLibs.120.00_12.0.21005.1_x86__8wekyb3d8bbweAppxManifest.xml”
      Add-AppxPackage -DisableDevelopmentMode -Register “C:Program FilesWindowsAppsMicrosoft.VCLibs.140.00_14.0.24123.0_x64__8wekyb3d8bbweAppxManifest.xml”
      Add-AppxPackage -DisableDevelopmentMode -Register “C:Program FilesWindowsAppsMicrosoft.VCLibs.140.00_14.0.24123.0_x86__8wekyb3d8bbweAppxManifest.xml”
      Add-AppxPackage -DisableDevelopmentMode -Register “C:Program FilesWindowsAppsMicrosoft.NET.Native.Framework.1.2_1.2.23231.0_x64__8wekyb3d8bbweAppxManifest.xml”
      Add-AppxPackage -DisableDevelopmentMode -Register “C:Program FilesWindowsAppsMicrosoft.NET.Native.Framework.1.2_1.2.23231.0_x86__8wekyb3d8bbweAppxManifest.xml”
      Add-AppxPackage -DisableDevelopmentMode -Register “C:Program FilesWindowsAppsMicrosoft.NET.Native.Framework.1.3_1.3.24201.0_x64__8wekyb3d8bbweAppxManifest.xml”
      Add-AppxPackage -DisableDevelopmentMode -Register “C:Program FilesWindowsAppsMicrosoft.NET.Native.Framework.1.3_1.3.24201.0_x86__8wekyb3d8bbweAppxManifest.xml”
      Add-AppxPackage -DisableDevelopmentMode -Register “C:Program FilesWindowsAppsMicrosoft.NET.Native.Runtime.1.1_1.1.23406.0_x64__8wekyb3d8bbweAppxManifest.xml”
      Add-AppxPackage -DisableDevelopmentMode -Register “C:Program FilesWindowsAppsMicrosoft.NET.Native.Runtime.1.1_1.1.23406.0_x86__8wekyb3d8bbweAppxManifest.xml”
      Add-AppxPackage -DisableDevelopmentMode -Register “C:Program FilesWindowsAppsMicrosoft.NET.Native.Runtime.1.3_1.3.23901.0_x64__8wekyb3d8bbweAppxManifest.xml”
      Add-AppxPackage -DisableDevelopmentMode -Register “C:Program FilesWindowsAppsMicrosoft.NET.Native.Runtime.1.3_1.3.23901.0_x86__8wekyb3d8bbweAppxManifest.xml”
      Add-AppxPackage -DisableDevelopmentMode -Register “C:Program FilesWindowsAppsMicrosoft.NET.Native.Runtime.1.4_1.4.24201.0_x64__8wekyb3d8bbweAppxManifest.xml”
      Add-AppxPackage -DisableDevelopmentMode -Register “C:Program FilesWindowsAppsMicrosoft.NET.Native.Runtime.1.4_1.4.24201.0_x86__8wekyb3d8bbweAppxManifest.xml”
      Add-AppxPackage -DisableDevelopmentMode -Register “C:Program FilesWindowsAppsMicrosoft.WindowsStore_11610.1001.10.0_x64__8wekyb3d8bbweAppxManifest.xml”
      Add-AppxPackage -DisableDevelopmentMode -Register “C:Program FilesWindowsAppsMicrosoft.StorePurchaseApp_11608.1000.2431.0_x64__8wekyb3d8bbweAppxManifest.xml”
      Add-AppxPackage -DisableDevelopmentMode -Register “C:Program FilesWindowsAppsMicrosoft.DesktopAppInstaller_1.0.2181.0_x64__8wekyb3d8bbweAppxManifest.xml”

      After that Windows Store launches … BUT no Apps install … no solutions !

      But you can install Windows 10 Apps by power shell …
      I have tested working :
      WindowsCalculator
      WindowsMaps
      BingNews
      Edge
      Word Mobile
      Excel Mobile
      Powerpoint Mobile
      OneNote
      Photo

      But Games not working :
      Asphalt 8: Airborne
      Microsoft Solitaire Collection

    • #61286
      Anonymous

      Well, it seems the most valuable things you can install will work; Edge, and WSL — so that’s a good thing…

      Why Microsoft wouldn’t make installing WSL on the Server OS where things like SSH and access to *NIX is especially valuable a bit easier is difficult to fathom…

Viewing 5 reply threads
  • You must be logged in to reply to this topic.