Unique security issue across my network using SQL 2005

Forums Operating Systems Windows Server 2008 R2 Miscellaneous Unique security issue across my network using SQL 2005

Viewing 16 reply threads
  • Author
    Posts
    • #50920

      Can anyone with server experiance help, please?

    • #50921

      Have you tried changing the Authentication mode from Kerberos to NTLM?

      1. In SQL Server Management Studio Object Explorer, right-click the server, and then click Properties.

      2. On the Security page, under Server authentication, select the new server authentication mode, and then click OK.

      3. In the SQL Server Management Studio dialog box, click OK to acknowledge the requirement to restart SQL Server.

      Courtesy: http://msdn.microsoft.com/en-us/library/ms188670.aspx

      See if that helps.

    • #50922

      Thank you for the responce.

      Under the authentication type I have 2 choices;

      Windows Authentication Mode

      SQL Server and Window Authentiation Mode

      SQL Server and Window Authentiation Mode was selected by default. Changing it to just the
      Windows Authentication Mode made no change. Also I never had to do this with Server 2008 and I am not sure what MS has changed in terms of security from 08 to 08R2 to give this issue. I am certainly far from being an expert in this dept.

      Thank you again and please any more advise. I really do not want to go through another format and reinstall of all my porgrams and settings. 😕

    • #50923

      You could type the error code here on the forum that it displays when you try to authenticate using credentials from the client machine?

    • #50924

      I have Server 2008 and I exported the Local Security Policy settings from my machine in the attachment below. Just extract the .zip and the security template (.inf) is in there.

      1. Go to Start > Administrative Tools > Local Security Policy

      2. In Local Security Policy, go to Action > Import Policy…

      Navigate to the location where you saved server2008securitytemplate.inf and import it into your machine. Your machine will now be matched with the same local security policy as 2008 hopefully this will work. Probably not but worth a shot. I’m no expert myself just offering us what I can bring to the table. Atleast we’ll be able to use a process of elimination to figure out what is causing this. Maybe its a read/write issue? When you ported to R2 did you take ownership of any specific folders which might be prohibiting the connection?

    • #50925

      The best way I can show you is the attached img…

      MyMovies has a client version and a Server version. The server version installs a light version of My SQL 2005. My Movies interacts with Windows Media Center and creates it own strip within it. When WMC is launched and the strip selected you can see all your movies/videos and then select and play them from the strip.

    • #50926

      Ok will give it a shot and get back to you ASAP.

      Thanks!

    • #50927

      TCP Port 1433: Microsoft SQL Server port used typically for remote connections to the database.

      Do you have TCP port 1433 forwarded on your router? When you re-installed the OS your private IP address (192.168.x.x) probably changed and its not matching the one you put in router. For example if you IP address in 2008 was 192.168.0.2 and you forwarded port 1433 to 192.168.0.2, in R2 it will not work because your address might be something other than 192.168.0.2.

    • #50928

      Actually after the format the local IP 192.168.1.x stayed the same. I never had to forward any ports in the router. The only thing MM tells you to do it for allow 2 .exec through the firewall, but even if I disable the firewall completely both private and public I still cannot connect so I do not think it is a port issue. Sadly your security policy did not work. 🙁

    • #50929

      Yeah I didn’t think it had anything to do with a firewall issue because you are staying inside your internal network (intranet) and thus port forwarding is not necessary.

      I was reading on this forum relating to your issue and here’s what someone had to say:

      “I followed the steps above, but still had no luck connecting a clients to the server. I looked at the sharing properties for the “FileStorage” share and noticed that “Users” was not listed under “People to share with” list. I tried adding it, but it wouldn’t take. So, I added “Everyone” with read/write privelages, and BAM! ITS WORKING!!!!”

      I don’t have the program installed so if you know where the heck the “FileStorage” share folder is, trying adding the “Everyone” group read and write permissions and see if that fixes it.

    • #50930

      Yea not really sure, still tryingto find the share you are talking about, got a link? What a pain in the neck.

    • #50931

      I found shares and MM is one of them out of the programdata older and everyone is already in the list so no go there…

    • #50932

      Just out of curiosity what happens when you change the name of your computer from mediaserver-pc to something like Marcus-PC? Did you have the same exact hostname on 2008 as you have in R2 currently?

      So much hassle lmfao and they say R2 is better. Not necessarily. I’ve had nothing but problem with R2 and will never go back to it. Praise 2008!

    • #50933

      I am sorry bro, I had it, the kids are going to want to watch their movies tomorrow, 2 and a 3 year old and they are hooked on Tinkerbell, lol… I have had it, I have messed with this thing all weekend and wasted nothing but time. I am currently installing Windows 7 64 bit just to give it a try and see if it has the same issue. If it does I have a backup img of my server 2008 install and I will just revert back. Really the main issue that made me switch in the first place is I could not get Verizon Media Manager installed properly on server 2008. I had an earlier version of it installed and running but I cannot get the new version to run. Man oh man computers, sometimes I want to take all of them in my driveway put’em in a pie and break out the lighter fluid…

      I’ll post back and let you know the results. Thanks again for all your time and help.

    • #50934

      Ok Win 7 worked out of the box by using the HomeGroup feature. Now I can access the server with all the clients… Going to miss server, one day if I am really bored I may bang my head again. 😯 😆

      Thank again for trying to help man. Take care.

    • #50935

      Windows Home Server V2 is based off Server 2008 R2’s core maybe you can get “My Movies” to work on WHS and centralize all your media data to a true server which might simplify everything for you in the future.

    • #50936

      For sure I will check it out. I tried V1 and really did not care for it being it was based off the old 2003 core. Reminds me to much of XP 😆 and really I wanted the better file tranfer speeds you get with the new OS compared with the old OS’… I will have to grab a copy of the beta and check it out, thanks again for all your help.

      PS: at least V2 will have homegroup option for n00bs like me 🙂

    • #44076

      First off this is my first post and I want to thank all the creators and their hard work. I have been using Server 2008 workstation for some time now but I needed to format due to reg issues and I fiqured why not upgrade to R2 and take advantage of the latest and greatest.

      I use my Server primarily as a Home Media Server to deliver all my video content across a program caled My Movies, http://www.mymovies.dk/ to all my Windows 7 clients on my network. My Movies i’ll refer to as MM catologs my video collection in a SQL 2005 DB and this is where my problem lies. With Server 2008 I did not have this connection issue but with R2 I cannot seem to get the clients to connect without adding an account on the server that matches the client. Again the issue is my clients cannot connect to the MM database unless I make a local account on the R2 server that matches that of the client. Also I have to add a password to the client machine which really complicates the simplicity of connecting to MM just to play a movie! Without that specific account I cannot connect, so I know it is a security issue R2 side but I cannot fiqure out what setting to lax or turn off and that is why I am asking for help.

      Thank in advance.

Viewing 16 reply threads
  • You must be logged in to reply to this topic.