Teamviewer 4.0 – only commercial

Forums Operating Systems Windows Server 2008 Applications Compatibility Teamviewer 4.0 – only commercial

Viewing 13 reply threads
  • Author
    Posts
    • #43594

      Hi,

      i installed Teamviewer 4.xx on 2008 Server. http://www.teamviewer.com

      But i can only installed this software for commercial use on server 2008.

      On vista, Server 2003, 2000 it can be installed for free use.

      I think, there is a registry key for the version….

      Can i change this, to install this software.
      Can anyone help me to find out which keys must changed?

      br
      Michael

    • #48136
      Arris
      Moderator

      Hello Michael,

      You are right about that the installation is checking a registry key (HKLMSYSTEMCurrentControlSetControlProductOptions), but we can’t avoid that so easily. However, I managed to install the personal edition.

      1. Download and Run the installer downloaded from http://www.teamviewer.com/. On the Welcome page click Next, directly after that at the Environment page click Back.
      2. Leave the installation window open and start Windows Explorer. Now go to your temp directory by typing %tmp% into the location bar.
      3. Go to the Detailed view (View -> Details), and sort at the Date modified column.
      4. Open the nsxXXXX.tmp directory (where the Xes are some random characters/numbers) and open the environment.ini file with Notepad.
      5. Change the value of Flags= of Field 1, 2 and 3 from DISABLED into GROUP|NOTIFY so you have Flags=GROUP|NOTIFY.
      6. Change the value of State= of Field 1 into 0 and the value of State= of Field 2 into 1.
      7. Save and close the file. Now right click the environment.ini file, choose Properties, check the Read-only flag and click OK to save the change.
      8. Maximize your installation window again and click Next to go to the screen where you can now choose the personal version! 🙂

      Maybe there is a quicker way, but at least this works. :geek:

      Good luck!

    • #48137

      Hi Arris,

      thanks for your tipps…
      I try it out today….

      I write back an answer.

      Michael

    • #48138

      Hi again,

      i doesn´t work….

      I installed it again with the changes from your previous post.
      It can be installed only with write-flag is set in the properties of the environment.ini file after select the non-commercial / private use.
      (I can change the value to non-commercial / privat use in the setup).
      After the installation is complete and i start the programm i can wait 1 or 2 seconds an then is in the statusbar the information “Trial 2 day´s left”.

      Is it another way to install this programm?

      I think, there is a registry key where the settings are stored (Time left,…)
      But where????

      br
      Michael

    • #48139
      Arris
      Moderator

      Hello, I installed the program again to test it and here is the proof that it works fine. Maybe it doesn’t work because you already installed the commercial trial once? You can try to remove the key HKEY_LOCAL_MACHINESOFTWARE(Wow6432Node)TeamViewer from the registry, delete the folder from the Program Files directory and try again…

      Hope this works for you!

    • #48140

      Hi again,

      the programm works now!!!

      But i solved this problem on a other way:

      Install Teamviewer, then install like the programm mean (commercial). After this, i started the programm, an it´s told me i have only 2 days left to test.
      In the options (or extras) menu there is an option like this (i forgot to write this down!!) “more testing time” or something else…
      Ok, i fill out the form (which pop up) an agree to private use.
      After i restart the programm i have this:

      http://www.bluetronics.de/Teamviewer-SVR2008.jpg

      Thanks a lot for your tipps and your help!!!

      Michael

    • #48141
      Arris
      Moderator

      It’s good to hear that! I’m glad you solved it that way! 🙂

    • #48142

      Since a few minutes a have another easy solution: Change the installer to run in compatibility mode (XP SP 2) and then run the installer as administrator. Then all you have to do is to say “private use”, now it is not greyed out. The rest is your decision.

      That’s it.

    • #48143

      You can extract the “portable” Teamviewer from the installer using 7zip. This will run on Server 2008 and you won’t even need to install it. To do this you have to extract the downloaded Teamviewer installer twice. Extract, then extract the output a second time into a subdirectory. In one of those subdirectories you’ll find Teamvierwer portable which can be run by simply double clicking it. Very nice tool by the way ! Even my mother can run it, straight from the attachment I mail to her when she calls with a question that’s pretty hard to answer by phone to someone who doesn’t know what Explorer is and can’t find anything that isn’t an icon on the desktop.

    • #48144

      I have ws2k8 on several machines on most of them I just ran the installer in xp compatibility mode and it installed just fine as non commercial but on one of my systems I really needed it in a hurry so I just installed it in trial mode but once the trial expired I cannot use it in any way without a license. Do any of you know where it saves the trial expired data in the registry? I used process explorer but I couldn’t find it because of the thousands of keys it accesses. All I have to do is get rid of that so I can install it in the free mode.

    • #48145

      I did same mistake and now I m trying to search for the licence of Teamviewer 5 but I m using windows 2003 enterprise edition.

      Anyone knows where i can found and delete the trial edition from regedit ?

    • #48146

      I have followed all your instructions. However I do deal with the trial expired window when I try to run it. I deleted the registry you mentioned but it does not work. Any ideas?
      Anyone knows where i can found and delete the trial edition from regedit ?

    • #48147

      dude It works and it works like magic…. great…..! Thankx a lot… amazing forum love the troubleshooting part…

    • #48148

      The second post (by Arris) was what did it for me, with TV version 8.

Viewing 13 reply threads
  • You must be logged in to reply to this topic.