Software RAID-5 on 780G

Forums Operating Systems Windows Server 2008 R2 Miscellaneous Software RAID-5 on 780G

Viewing 0 reply threads
  • Author
    • #44359

      Hi Everyone,

      Short story:
      I’m trying to use software raid-5 in R2 on 4x WD15EARS and I’m getting max 45mb/sec write to the array, and while writing (even as low as 20mb/sec) I get stutter when playing video files (tried multiple files, sources, codecs). Is it normal?
      (system spec at the bottom)

      Long Story:
      I have set up my HTPC with 2008 R2 using the guide and I must say, it is working wonderfully.

      I have been wondering if anyone else tried using the R2 RAID-5…

      I got my hand on 2 more drives (WD15EARS) on the cheap from a friend, so I wanted to used the raid 5 instead of making a second raid-1 array wit the 2 new drives.

      I was using the software raid because of 1 simple reason:
      Since this machine also holds my file server, I wanted to make sure to be able to transfer the array in case I decide to put the file server in another box, or if the motherboard goes belly up.

      Raid-1 was working perfectly and I confirmed that I was able to move the array between OS and architecture. ( I transferred the array from a windows 7 x86 install to the present R2 x64. )

      I got the data off the existing array and got the Raid-5 built…

      Those that used it or know about it are laughing right now…. 😆

      4 days later… the array is FINALLY initialized… (by now I’m already shopping for raid cards on ebay…)

      I was happy for about 5 minutes…

      I started to copy files on the array, and started back mediaportal.

      Apparently, when I get “heavy IO” (writing to the array), I can’t play anything.

      I have tried multiple sources (including different codecs) and multiple players.

      Yes the CPU usage is up from idle, which is normal for software raid, but not enough to cause such stuttering.

      I also get very low write speed to the array, around 45mb/sec max.

      Just wondering if anyone have any ideas on what is going on…

      My best guess at present are either this is caused by software raid itself, not being to calculate parity fast enough, even though it could be doing it faster if I judge by the CPU load


      The controller is getting bottlenecked by the array and can’t manage to process the data fast enough

      Wow… sorry for the long post…

      Added the short version, and this to help:

      I’m using a 4850e (2.5ghz X2) on a Gigabyte GA-MA78GM-S2H, Radeon 5450, 2gb DDR2-800, boot disk is a 60gb Corsair Nova

Viewing 0 reply threads
  • You must be logged in to reply to this topic.