Remote audio

Viewing 2 reply threads
  • Author
    Posts
    • #44067

      I have audio working on my system (Win2K8 R2, Gateway GT5654 PC, Realtek audio). I’m using the Vista x64 audio drivers, which is the closest I could find.

      The WinAudio service is running, and audio works fine when I log in to the local console. But when I RDP in, even if I select “Bring to this computer”, I don’t get sound. When I’m remoted in, the speaker icon in the tray shows a red “x”, and the mixer says “No audio devices are installed.”

      Any thoughts?

      Thanks,
      Erik J Sawyer

    • #50883

      I found it!

      1. Under Administrative Tools/Remote Desktop Services, choose “Remote Desktop Session Host Configuration”.
      2Under “Connections”, right-click the RDP-Tcp connection, and choose Properties.
      3. Click the “Client Settings” tab
      4. In the redirection box, anything that is checked will *not* be redirected. My setup had “Audio and video playback” and “Audio recording” checked. Uncheck them.
      5. My setup also had the “Limit Maximum Color Depth” checked, and set to 15bpp. I unchecked the limitation.

      Once those settings are changed and saved, disconnect the RDP session (if you’re currently in one) and reconnect. The settings will take effect.

    • #50882
      Arris
      Moderator

      I’m glad you solved it! 🙂 This info is also more or less available at the Enable Remote Desktop with Aero page in the manual.

Viewing 2 reply threads
  • You must be logged in to reply to this topic.