Realtek 8111B "could not find the file specified" & code 31

Forums Operating Systems Windows Server 2008 Hardware Compatibility (New) Realtek 8111B "could not find the file specified" & code 31

Viewing 1 reply thread
  • Author
    Posts
    • #47814
      AvatarArris
      Moderator

      Hey technx,

      First thing you can do is to follow the Extended Outpost Uninstall/Reinstall Instructions.

      If that doesn’t work out, you can try is to download Sysinternals Autoruns, start autoruns.exe and go to the Network Providers tab. Maybe you see some files that are referenced that still belong to Outpost. Also take a look at the Drivers and Winsock Providers tab to find out if there are still any Outpost drivers referenced. Uncheck/delete them too.

      Last thing I can think of is the netsh winsock reset command in the console (cmd.exe) to reset your Winsock Catalog to the default settings.

      Hope one of these methods works! 🙂

      Arris

    • #47815

      Thanks for the info Arris, but I ended up doing a format and clean install. I was surprised to find out that there isn’t a Repair option on the windows 2k8 install cd like windows xp. I had to do a clean install. Things seem to work now, thanks.

    • #43506

      I’m using Server 2008 x64 and my Realtek 8111B onboard NIC was working fine for over a month. I tried to install Outpost Firewall and it froze during setup while installing network drivers, so I did a ctrl-alt-del to end the installation process.

      After that happened, my NIC and other network drivers like the WAN miniport drivers have exclamation marks on them in the device manager.

      The error that I see is code 31 and it says “Could not find the file specified”.

      I’m afraid I may have corrupted my NIC drivers because of stopping the Firewall installation midway. I’ve tried to reinstall the driver manually many times and that doesn’t work. When I look at the driver details it shows the driver file is installed in C:WindowsSystem32 and I checked that the file was actually there, but it still comes up with the “”Could not find the file specified” error

      And for some reason I can’t uninstall the WAN miniport drivers, theres about 5 of them, they say IPv6, PPoE, etc…

      I also have another version of Windows on dual boot that also uses Vista x64 drivers for my NIC and it works fine, so I don’t think NIC has a physical problem.

      I didn’t do any backups recently and don’t have System Restore installed.

      Anyone have suggestions how I can solve this without having to reinstall Server 2008?

Viewing 1 reply thread
  • You must be logged in to reply to this topic.