Need Help Getting Bluetooth To Work on R2

Forums Operating Systems Windows Server 2008 R2 Hardware Compatibility Need Help Getting Bluetooth To Work on R2

Viewing 3 reply threads
  • Author
    Posts
    • #51600

      1. Try starting the Windows Installer service before beginning installation and see if that fixes problem. I’ve ran into that occasionally when Windows Installer is running in manual mode and the installation doesn’t always start the Windows Installer service for you. Don’t ask me why, i’ve just noticed it happen to me from time to time.

      2. Install the latest possible chipset drivers for your MOBO (not the ones on the CD)so that your board can effectively communicate with your wireless USB bluetooth device. Your chipset may have driver support that includes your intel PROset bluetooth device and thus why its not working. I doubt this is the solution but its worth a quick fix if it does work.

      3. Try installing the package as an “unsigned driver”. Restart your PC and continously hit F8 until you see advanced boot options, next choose “Disable Driver Signature Enforcement”

      You might need to find a way to unpack that installation file and trick it into thinking your run 7…I’ve noticed a lot of Intel software packages hate R2. Example…Intel Desktop Control Center.

    • #51601

      Just figured i would provide an update on this, after installing the Bluetooth stack and running the BT drivers from the ASUS provided disc (i used the provided autoinstaller, not manual installation by running the files individually) that i modded and reburned, they installed correctly. It seems to be working ok but i suspect that i’m still missing a few features. I called both ASUS and Intel, they both state that they cant (translate: wont) help me because i’m running an unsupported OS.

      I say this because when i download the updated BT drivers from ASUS support site and try to install them, the latest one labelled as Intel fails with the same error you see in my first post.

      But when I install from the disc on 7 and then try to run the updated drivers on ASUS site, they install fine.

      I would also like to note that there are 3 packages contained on the disc, one is from Azurewave/Atheros. that is the Bluetooth Suite itself, installs correctly on both r2 and 7. there are also 2 other files under the Intel folder, one folder is labelled “Intel BT”, and the other is labelled “Intel BT 3.0 HS”, which means high-speed 3.0. i can manually install both of those under 7 and they both show under Control Panel as being installed. When I go to the Program Files/Program Files (x86) directories, respectively, both can be found. But under R2 only the 3.0 HS one is installable, the IntelBT one from my first post is the one that gives the error.

      Also, the updated Intel from ASUS is the non-HS 3.0 one. have also tried the generic non-HS 3.0 from Intel, it also fails. But i cant seem to find a direct link on the Intel site for the 3.0 HS, can anyone try to find a link for that?

      i really dont think that the package is corrupted, as the installer seems to be implying, i think R2 is the cause.

      And to halladayrules, i tried all your advice, none worked. 2 questions though. one is regarding the MOBO drivers. i see a folder on the disc labelled “Chipset” by Intel with a folder within Intel labelled “INFUpdate”. is that the MOBO driver? i dont think it is, intel makes my processor but ASUS makes my MOBO. i cant find anything else on the disc that seems to be related to the MOBO. where can i find my MOBO drivers, the ASUS site doesnt seem to have them available for download (maybe i’m just looking in the wrong areas)?

      Also, how can i trick drivers into thinking i’m running 7? i know one method is to mod the actual driver files themselves, which is essentially what i did by modding a few .ini files on the disc to trick it into not checking my OS Version. But i have also heard about some registry entries somewhere, and theoretically if you change those to 7 values then………..well, you get my point. but that just seems a bit dangerous. have also tried Orca numerous times with various drivers/software, with some success.

      For now i’m going to try not to worry about BT very much since it seems to be working, but i would like to try to dig up some answers anyway. also, if anyone can take a look at the file i uploaded in the first post then it would be appreciated. there seems to be be something in that file that implies that a file couldnt be “RegServer” during the install process.

      if anyone has any feedback then reply soon.

    • #51602

      viewtopic.php?f=25&t=929

      Its all been solved. Run asciiwolfs installer thingy first that disables code signing.

    • #51603

      To Rainwulf: no offense intended, but if you had bothered to read my posts carefully then you would have noticed that i explicitly stated that i installing the BT stack BEFORE installing the BT drivers……………..

    • #44186

      Yesterday i posted a topic in which i stated that I had gotten all OEM-provided drivers working under R2 on my new laptop. Well, i take that back, almost all of them except Bluetooth. I first noticed the issue after checking Device Manager and seeing that Windows had flagged my device as not working under the BT category. I have tried the OEM-provided drivers, and a package that i downloaded directly from the Intel Downloads Center.

      Before doing this, i made sure to install the BT Stack as provided on this forum (NOT the one from the R2 Workstation Converter, as it gave an error after trying to apply it). I think it was created by either Arris or AsciiWolf, not sure. But anyway, when i try to run either of the installer packages, it caches the files to HDD, asks me to accept the terms of the license agreement, and then begins copying files to Program Files (x86) directory. But about 75% of the way through it pauses for a few seconds and then errors out with the below screenshot:

      Im also attaching a copy of the log file as well.

      Thanks for any help!

Viewing 3 reply threads
  • You must be logged in to reply to this topic.