MICROSOFT SERVER CONVERTER 2012 R2

Forums Operating Systems Windows Server 2012 R2 Miscellaneous MICROSOFT SERVER CONVERTER 2012 R2

Viewing 39 reply threads
  • Author
    Posts
    • #60854
      AvatarAnonymous

      Hey Mate, any chance of grabbing a copy from you, even if its beta πŸ™‚

    • #60855
      AvatarAnonymous

      @matlear wrote:

      Hey Mate, any chance of grabbing a copy from you, even if its beta πŸ™‚

      Not really as basically a part from collecting mui files from 8.1 x64 I have not done nothing else.

      I am a little busy at work and do not have much time for MSC project.

      Sorry about that.

      πŸ™‚

    • #60856
      AvatarAnonymous

      No Probs mate..

      No need to rush.. thanks for all your work πŸ™‚

    • #60857
      AvatarAnonymous

      I am making some progress and I hope to get it done by next week.

      TY for your patience.

      πŸ™‚

    • #60858
      AvatarAnonymous

      @ExpertUser wrote:

      I am making some progress and I hope to get it done by next week.

      TY for your patience.

      N πŸ™‚

      Looking forward to it, free websitespark MSDN account gives free 2012 R2 keys, converting to workstation = good things πŸ˜€

    • #60859
      AvatarAnonymous

      1st post updated.

      Performing last tests.

      N πŸ™‚

    • #60860
      AvatarAnonymous

      @ExpertUser wrote:

      1st post updated.

      Performing last tests.

      N πŸ™‚

      Is today the day ? πŸ˜€

      Thanks for putting so much time into this

    • #60861
      AvatarAnonymous

      1st post updated.

      N πŸ™‚

    • #60862
      AvatarAnonymous

      @ExpertUser wrote:

      1st post updated.

      N πŸ™‚

      Brilliant, thanks very much! πŸ˜€

      EDIT – Not seeing the Metro backgrounds in personalise, are they supposed to be there?

      PC Settings (Metro side) doesn’t seem to work either, it is only linked as an app which force closes when I open it, and the link in Charms bar is not there like in 8.1

    • #60863
      AvatarAnonymous

      @ExpertUser wrote:

      1st post updated.

      N πŸ™‚

      ok, I’m getting some “access denied” errors on bda and system restore on packs


      Cannot create C:WindowsSystem32en-uskswdmcap.ax.mui
      Access is denied.
      Returned Win32Result: 1.
      ...
      Cannot create C:WindowsSysWOW64en-usrstrtmgr.dll.mui
      Extracting C:WindowsSysWOW64en-ussxproxy.dll.mui 95% OK
      Access is denied.
      Cannot create C:WindowsSysWOW64en-ussppc.dll.mui
      Access is denied.
      Cannot create C:WindowsSysWOW64en-ussppcext.dll.mui
      Extracting C:WindowsSysWOW64en-usspp.dll.mui 96% OK
      Total errors: 3
      Access is denied.
      Returned Win32Result: 1.

      converter is run by built-in admin as admin, and by an admin user as admin,
      following the procedure (features first, restart, then services, restart, then packs)
      either way the same “access denied” errors
      but, on second run, right after the first, without restarting in between,
      it seems (not sure though) to install both ok (system restore works, haven’t tested bda)
      any thoughts?

      PS1: btw, thanks for the converter, fantastic job as always, saves a lot of time
      thanks for your dedication, keep up the great work
      PS2: wth happened to the (rightfully yours) domain?
      somebody snatched (just two months ago) http://www.win2012r2workstation.com ?

    • #60864
      AvatarAnonymous

      TY for the feedback.

      System Restore needs to have Windows Backup already installed to run, you cannot run it the same time you enable WB. Same for BDA with Dekstop Experience.

      Arris will take care of the domain issue. No worries.

      N πŸ™‚

    • #60865
      AvatarAnonymous

      @Detection wrote:

      @ExpertUser wrote:

      1st post updated.

      N πŸ™‚

      Brilliant, thanks very much! πŸ˜€

      EDIT – Not seeing the Metro backgrounds in personalise, are they supposed to be there?

      PC Settings (Metro side) doesn’t seem to work either, it is only linked as an app which force closes when I open it, and the link in Charms bar is not there like in 8.1

      When in start screen Win+I brings up Settings and submenu Personalize
      from there you can select background and accent color,
      the new metro (modern?) backgrounds from 8.1 (that adjust to your position on the screen)
      are not available (I can’t find them anywhere anyway)

      Also when in start screen or the desktop or anywhere else
      Win+I brings up Settings and submenu Change PC Settings
      this brings up the same PC Settings as win 8.1
      (without some menus like skydrive, pin & picture password, microsoft account, homegroup and file history, as far as I can see)

      If you haven’t activated you can’t change some settings (as your lock screen)
      but other than that the PC Settings seem to work fine (for the built-in admin too)
      The link in the Charms Bar is there as well

      Maybe try reinstalling or sfc /scannow ?

    • #60866
      AvatarAnonymous

      @ExpertUser wrote:

      TY for the feedback.

      System Restore needs to have Windows Backup already installed to run, you cannot run it the same time you enable WB. Same for BDA with Dekstop Experience.

      Arris will take care of the domain issue. No worries.

      N πŸ™‚

      yeah, installed features first (including windows backup and desktop experience), restarted,
      enabled services, restarted, and then tried to enable system restore and bda from packs tab.
      need any logfiles?

    • #60867
      AvatarAnonymous

      @ledzep wrote:

      @ExpertUser wrote:

      TY for the feedback.

      System Restore needs to have Windows Backup already installed to run, you cannot run it the same time you enable WB. Same for BDA with Dekstop Experience.

      Arris will take care of the domain issue. No worries.

      N πŸ™‚

      yeah, installed features first (including windows backup and desktop experience), restarted,
      enabled services, restarted, and then tried to enable system restore and bda from packs tab.
      need any logfiles?

      TY. No logs files are required.

      And I appreciate the feedback.

      N πŸ™‚

    • #60868
      AvatarAnonymous

      @Detection wrote:

      @ExpertUser wrote:

      1st post updated.
      PC Settings (Metro side) doesn’t seem to work either, it is only linked as an app which force closes when I open it, and the link in Charms bar is not there like in 8.1

      I can confirm that PC Settings charm works upon fresh install yet is broken after running one of the options in the converter (also by doing the steps manually of the website).
      After reinstalling a bunch of times and selecting only parts of the options in the converter I have found that I can use almost all of the options without PC Settings getting broken.
      I can run all of the options under Server Features, Services, W81Packs2012R2, and Fixes.

      That means one of the options in Tweaks breaks PC Settings. Still trying to figure out which one.

      I am stopping here. I can enable all settings in the first 4 tabs, as well as the following in the last Tweaks tab. If I enable anything else I get PC Settings broken, not sure what but I got tumbnails by doing it manually and I don’t hear stuttering. I have enabled option Disable Shutdown Event Tracker, Diable Cntr-lalt-delete, enable performance mode, add take ownership, diable sehop, turn on dep, enable store.

      So to the other person that has PC settings broken, reinstall the os and don’t check all the boxes, I bet you are running into the same issue.

    • #60869
      AvatarAnonymous

      @spalek83 wrote:

      @Detection wrote:

      @ExpertUser wrote:

      1st post updated.
      PC Settings (Metro side) doesn’t seem to work either, it is only linked as an app which force closes when I open it, and the link in Charms bar is not there like in 8.1

      I can confirm that PC Settings charm works upon fresh install yet is broken after running one of the options in the converter (also by doing the steps manually of the website).
      After reinstalling a bunch of times and selecting only parts of the options in the converter I have found that I can use almost all of the options without PC Settings getting broken.
      I can run all of the options under Server Features, Services, W81Packs2012R2, and Fixes.

      That means one of the options in Tweaks breaks PC Settings. Still trying to figure out which one.

      I am stopping here. I can enable all settings in the first 4 tabs, as well as the following in the last Tweaks tab. If I enable anything else I get PC Settings broken, not sure what but I got tumbnails by doing it manually and I don’t hear stuttering. I have enabled option Disable Shutdown Event Tracker, Diable Cntr-lalt-delete, enable performance mode, add take ownership, diable sehop, turn on dep, enable store.

      So to the other person that has PC settings broken, reinstall the os and don’t check all the boxes, I bet you are running into the same issue.

      No need to look any further, if you tick “Enable automatically boot to Classic Desktop” then PC Settings is disabled.

      But if you look well and you did not, there is also a Disable function for it and there was no need to perform a new install of your OS.

      Message to all : please read before applying features/tweaks/fixes. If you do not know what is does then post here, we will explain you.

      This is the major issue with PC users : NOBODY READS…….. πŸ˜† πŸ˜† πŸ˜†

    • #60870
      AvatarAnonymous

      Awesome work! Thank you VERY much for this.

    • #60871
      AvatarAnonymous

      Thanks for good work helping the community, ExpertUser πŸ™‚

    • #60872
      AvatarAnonymous

      TY folks.

      N πŸ˜‰

    • #60873
      AvatarAnonymous

      Anyone succeeded to run SkyDrive on R2?
      In 8.1 it is deeply integrated, I couldn’t make it work on converted 2012 R2…

    • #60874
      AvatarAnonymous
    • #60875
      AvatarAnonymous

      I’m having trouble installing BDA support.

      I had Server 2012 (non-R2 standard edition) running my HTPC, and had added BDA support with the tool from the Tenniswood Blog – http://www.tenniswood.co.uk/technology/windows/adding-bda-support-into-windows-server-2012/

      The other day, I did an upgrade to Server 2012 R2 Datacenter Edition, and the BDA support broke. I installed your M$ converter, M$ feature already had desktop experience enabled. Enabled desktop exp. in the converter. Rebooted. Tried enabling converter’s BDA support, and received an error.

      I backed everything up, and did a clean Server 2012 R2 Datacenter install. Enabled M$ desktop experience feature. Rebooted. Enabled converter desktop experience. Rebooted. Got the same error trying to enable BDA support.

      “Microsoft Server Converter – Result”
      “One or more items failed to install properly”

      Any tips?

      Thanks!

    • #60876
      AvatarAnonymous

      @Fragster wrote:

      I’m having trouble installing BDA support.

      I had Server 2012 (non-R2 standard edition) running my HTPC, and had added BDA support with the tool from the Tenniswood Blog – http://www.tenniswood.co.uk/technology/windows/adding-bda-support-into-windows-server-2012/

      The other day, I did an upgrade to Server 2012 R2 Datacenter Edition, and the BDA support broke. I installed your M$ converter, M$ feature already had desktop experience enabled. Enabled desktop exp. in the converter. Rebooted. Tried enabling converter’s BDA support, and received an error.

      I backed everything up, and did a clean Server 2012 R2 Datacenter install. Enabled M$ desktop experience feature. Rebooted. Enabled converter desktop experience. Rebooted. Got the same error trying to enable BDA support.

      “Microsoft Server Converter – Result”
      “One or more items failed to install properly”

      Any tips?

      Thanks!

      Look at log file in MSC installation folder in Program Files (x86) and check the line with the error, that will help you to understand what is wrong.

    • #60877
      AvatarAnonymous

      Hi,

      there seems to be a problem with the converter when using it on a Windows server 2012 R2 that is not English native.

      Even if the .mui ressources are correctly copied into the correct language folder of System32 and SysWOW64, they are not used.

      I have a french Windows Server 2012 and if I use, let say, WinSAT.exe, it remail into English, not using the .mui french translation.

      Any idea?

      Thanks.

    • #60878
      AvatarAnonymous

      I installed sticky notes but they didn’t launch after I clicked them. There were no errors on install or when I tried to launch them.

      On some of your previous installers I notuced that they would not work in every directory if ran as administrator. Here is some code to fix the administrator proub: cd /d %~dp0
      This code will change the current directory to the directory that the batch file is running from. I had to add this to make the Aero cursors installer work.

      P.S. I miss spelled my username when I signed up so can an admin please change it to “Elliot Labs” Thanks!

    • #60879
      AvatarAnonymous

      Hi

      This is my first post so please don’t crucify me.

      I have not used a Server OS as a workstation as yet, the conversion tool looks interesting. Is there a guide to using the tool, something simple [just pics] showing what to tick to get as close as possible to Windows 7/8? Many of the choices are straight forward but others mean nothing to me at all.

      I will use the manual conversion guide at some point in the future once I am comfortable with the system. For the time being I just want to get up and running asap.

      I take it that the oem_folder_srv2012r2 should be added to the iso image prior to installation, but where exactly?

      Any help would be appreciated.

    • #60880
      AvatarAnonymous

      First off, thank you. This tool is really useful.
      Most options worked flawlessly. There were a few hiccups due to file permissions, but the logs made those easy to track down.

      But there was one bizarre issue I found. I seemed to have fixed it for myself, but I still thought I should report it and post what I did.
      The problem is with the “Add msmpeg2enc.dll” option. Installing the option worked fine, but afterwards I encountered these errors when viewing “Administrative Events” in the Event Viewer:

      “muxencode – The specified channel could not be found. Check channel configuration.”
      “Microsoft-Windows-MPEG2-Video-Encoder-MFT_Analytic – The specified channel could not be found. Check channel configuration.”

      These logs don’t seem to exist in 2012R2, but Event Viewer was looking for them.
      On further investigation I found that the references to these logs were added by the converter. Specifically, they came from the “mpeg2enc_w8.reg” file.


      [HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindowsCurrentVersionWINEVTPublishers{86efff39-2bdd-4efd-bd0b-853d71b2a9dc}]
      @="Microsoft-Windows-MPEG2_DLNA-Encoder"
      "ResourceFileName"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,
      00,6f,00,74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,
      5c,00,6d,00,73,00,6d,00,70,00,65,00,67,00,32,00,65,00,6e,00,63,00,2e,00,64,
      00,6c,00,6c,00,00,00
      "MessageFileName"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,
      6f,00,74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,
      00,6d,00,73,00,6d,00,70,00,65,00,67,00,32,00,65,00,6e,00,63,00,2e,00,64,00,
      6c,00,6c,00,00,00

      [HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindowsCurrentVersionWINEVTPublishers{86efff39-2bdd-4efd-bd0b-853d71b2a9dc}ChannelReferences]
      "Count"=dword:00000001

      [HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindowsCurrentVersionWINEVTPublishers{86efff39-2bdd-4efd-bd0b-853d71b2a9dc}ChannelReferences]
      @="muxencode"
      "Id"=dword:00000010

      [HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindowsCurrentVersionWINEVTPublishers{d17b213a-c505-49c9-98cc-734253ef65d4}]
      @="Microsoft-Windows-msmpeg2venc"
      "ResourceFileName"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,
      00,6f,00,74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,
      5c,00,6d,00,73,00,6d,00,70,00,65,00,67,00,32,00,65,00,6e,00,63,00,2e,00,64,
      00,6c,00,6c,00,00,00
      "MessageFileName"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,
      6f,00,74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,
      00,6d,00,73,00,6d,00,70,00,65,00,67,00,32,00,65,00,6e,00,63,00,2e,00,64,00,
      6c,00,6c,00,00,00

      [HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindowsCurrentVersionWINEVTPublishers{d17b213a-c505-49c9-98cc-734253ef65d4}ChannelReferences]
      "Count"=dword:00000001

      [HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindowsCurrentVersionWINEVTPublishers{d17b213a-c505-49c9-98cc-734253ef65d4}ChannelReferences]
      @="Microsoft-Windows-MPEG2-Video-Encoder-MFT_Analytic"
      "Id"=dword:00000010
      "Flags"=dword:00000000

      Deleting the above entries made the errors in Event Viewer disappear. The deletion doesn’t seem to have affected anything, but I’m not an expert. Hopefully someone who knows better can provide more info. Perhaps there is a more proper fix?

    • #60881
      AvatarAnonymous

      @ wmn

      TY for the info. I will take a look at it.

      @ jcap511 and Elliot Labs

      TY for the modifications suggestions. Much appreciated.

      @ kim100

      By using the manual conversion guide you will understand the conversion options in MSC. There are pictures in the tool on how to run it.

      The $OEM$ folder needs to be added to “sources” folder.

    • #60882
      AvatarAnonymous

      Transperant start menu doesn’t work

    • #60883
      AvatarAnonymous

      Source:Windows 2012R2 DC Update3 MSDN

      System Restore Not Working!


      System Restore did not complete successfully. Your computer’s system riles and settings were not changed.

      Details:

      System Restore failed to extract the original copy of the directory from the restore point.
      Source: %ProgramFilesWindowsApps
      Destination: AppxStaging
      The restore point was damaged or was deleted during the restore.

      You can try System Restore again and choose a different restore point. If you continue to see this error,
      you can try an advanced recovery method.



      Please FIX.

    • #60884
      AvatarAnonymous

      @ryjakss wrote:

      Source:Windows 2012R2 DC Update3 MSDN

      System Restore Not Working!


      System Restore did not complete successfully. Your computer’s system riles and settings were not changed.

      IΒ΄m sorry, but I donΒ΄t understand your post.
      IΒ΄m confused… πŸ™„
      What has problems with System Restore to do with the SERVER CONVERTER 2012 R2 and this forum ?

      Please explain what you did when you got that errormessage.

    • #60885
      AvatarAnonymous

      @ryjakss wrote:

      Source:Windows 2012R2 DC Update3 MSDN

      System Restore Not Working!


      System Restore did not complete successfully. Your computer’s system riles and settings were not changed.

      Details:

      System Restore failed to extract the original copy of the directory from the restore point.
      Source: %ProgramFilesWindowsApps
      Destination: AppxStaging
      The restore point was damaged or was deleted during the restore.

      You can try System Restore again and choose a different restore point. If you continue to see this error,
      you can try an advanced recovery method.



      Please FIX.

      Yes same thing happen to me. Just reinstalled then all the updates. “system protection” tab is there and the button for System Restore there yet when you press it nothing happens.

      I am NO EXPERT HERE AT ALL. I opened Msc2012r2r2convpacksinst.cmd. I went down to where I saw rarsystem_restore.. and did every thing it tried to do. Just copying sr.xml didnt seem to work. So opening a admin cmd going to the dir where sr.xml is then .. just like it shows.. it works great now.

    • #60886
      AvatarAnonymous

      Is the converter multilanguage and multiuser multilanguage compatible?

      Thank you

    • #60887
      AvatarAnonymous

      Hi !
      Welcome to the forum.

      @riahc3 wrote:

      Is the converter multilanguage and multiuser multilanguage compatible?

      IΒ΄m sorry but I donΒ΄t understand what you mean.
      You have to run the converter as Administrator…. πŸ˜‰
      The language used is english.
      Install and start it, then you will see how it looks….

    • #60888
      AvatarAnonymous

      Downloads & Distfiles are not working anymore or are forcing you to load malware from these sites.

    • #60889
      AvatarAnonymous

      @gboos wrote:

      Downloads & Distfiles are not working anymore or are forcing you to load malware from these sites.

      Which downloads ?
      And what is “Distfiles” ?

      Where did you find the download link(s) ?
      Post the URL (address) of that page.

      Where did you download from ?
      Post the link.

      If you mean the links on page 1 in this thread, they are both working and are clean.
      I have checked them myself.

      If you have got malware when downloading then you have probaly made the same mistake as Paul Bunion….

      For more information please read the last post in this thread: viewtopic.php?p=11974#p11974

      DO NOT ACCUSE THIS FORUM OF SPREADING MALWARE IF YOU MAKE MISTAKES WHEN YOU DOWNLOAD.

    • #60890
      AvatarAnonymous

      @hackerman1 wrote:

      Hi !
      Welcome to the forum.

      @riahc3 wrote:

      Is the converter multilanguage and multiuser multilanguage compatible?

      IΒ΄m sorry but I donΒ΄t understand what you mean.
      You have to run the converter as Administrator…. πŸ˜‰
      The language used is english.
      Install and start it, then you will see how it looks….

      Is it compatible with other languages of Windows Server 2012 R2 and/or MUI?

    • #64217
      AvatarSSJ7BDylan
      Participant

      The download link from datafilehost is still working, but there’s a data error when I extract the archive. Could you please either fix that or send me the archive with no errors at all

    • #64497
      AvatarGigaWatt
      Participant

      Well, none of the download links are working now…

      Does anyone have the installer for the converter… I mean… what good will it do to anyone if you can’t download it.

    • #64498
      AvatarGigaWatt
      Participant

      Somehow, the datafilehost link is working now… but here’s a mirror just in case.

      https://cloud.mail.ru/public/5ddX/Yd5VrHhXb

    • #44695

      MICROSOFT SERVER CONVERTER 2012 R2 – v.1

      Like for 2012, M$ latest will have it’s own version of Microsoft Server Converter.

      There is basically no difference between the 2012 and 2012 R2 except that I updated all packs with files from Windows 8.1.

      I added Classic Shell RC to it too in case you wish to try out.

      Important :

      1/ If you have used MSC2012 (previous version) on Server 2012 R2 please do not use MSC2012 R2 again, there is no need as the tool will not be able to apply W81Packs2022R2 as files exist already.

      2/ If you have Server 2012 R2 already installed and you have enabled the Features via Server Manager and/or DISM with scritps, in order to install certain packs like System Restore you will need to enable in Features Tab “Windows Backup” again just in order to tell in scripts that it has been enabled since there is a dependency check. Same for packs like BDA Support, Cinepak and Sticky Notes that require Desktop Experience.

      3/ I hope you understand what I meant in 1/ and 2/…..

      Installation Directory : C:Program Files (x86)MSC2012

      Changelog 22/09/2012 :

      1/ Ported tool to Server 2012 R2

      2/ Added Windows To Go

      3/ Updated Classic Shell to Release Candidate Edition

      Here some screens :

      3

      DOWNLOAD LINKS :

      http://www72.zippyshare.com/v/49085405/file.html

      or

      http://www.datafilehost.com/d/27629593

      πŸ˜‰

Viewing 39 reply threads
  • You must be logged in to reply to this topic.