Installing Speech Recog

Viewing 3 reply threads
  • Author
    Posts
    • #43598

      Here is another go at what looks to still be an unsolved case. I have spent the last few hours scouring the internet for how to get this going, but it is still broken. Here is what I have found so far

      On sawo’s automated tool (1.21), clicking the apply button says “done” but doesnt tell you there was an error. You have to open the file in /data/speech/speech1.reg and replace the first line with “REGEDIT 4” This will allow it to merge. Also, looking at everything in it, there are many entries for other languages, such as chinese and german. I dont know if those are needed or not, but what caught my eye was that there is mention of English – U.K. but no mention of English – U.S. in the registry entrys that it adds. I tried replacing the K with and S, but it didnt change anything.

      In order for files to be moved from another vista install (Windows/speech and windows/system32/speech), permissions on the server 08 install folders must be changed. That I’m not going to deal with on how to do it. Sufficeth to say that dragging and dropping will fail because you dont have permissions in some of those folders to do anything. Also, since you evidently shouldnt replace the files already there, I recommend copying them to another folder, copying the vista files in, then copying them back in to overwrite anything that might have acidently been overwritten.

      So far, I am still stuck at having the speech recognition tab open and display an error that the “requested task cannot be carried out becase the necessary engine could not be created.” I have no idea where to go from here.

      I honestly dont see why this part of the utillity has been released yet. From what I have seen, it just isnt working. I’ve tried it on 2 clean installs and it just doesnt work. Thanks to Sawo for the great work on the rest of the converter, but this part still needs a lot of work.

      If anyone HAS gotten a failsafe way of installing, PLEASE SHARE. I hate reinventing the wheel.

    • #48155
      Arris
      Moderator

      Hello fred,

      Sawo got the instructions from the page Google Groups: Windows Server 2008 and Speech Recognition from Jason’s comment. However it seems the way they are implemented in the Converter application doesn’t work for all people using it. You can try to do it all manually by following the instructions at the post in the Google Groups mentioned before. If you don’t have a Vista installation you can also use a Vista DVD with the same architecture you have to get the files.

      To do this follow these steps:
      1. Download and install 7-Zip.
      2. Insert/mount the Vista x86/x64 dvd.
      3. Browse to the X:sources folder using Windows Explorer and open the install.wim file using 7-Zip.
      4. Browse through the folders and extract the files you need!

      Hope this post helps you to do not have to reinvent the wheel! 🙂

    • #48156

      Thanks for the tip, but thats one of the things I’ve already tried and it still hates me. I dont know why it would work on some systems and not others but so far none of the walkthoughs have liked me. The only thing I can figure now is that either my disks for server 08 is corrupted or that the files I copied from vista are bad.

      Another note, how did you guys get to be able to copy files into those folders? I am getting denied access even just trying to write into them and having to jump through hoops to get permission.

    • #48157

      Ok. I tried going over the whole process of reinventing the wheel again! (Man never gives up does he? :P) Anyhow, after everything, I realized that I could do it no better than it has already been done.

      However, I think I did something right and hope someone can pick it off from here and make it work. I did all that I could gather from the forum and also this: http://www.geekpedia.com/Thread16235_Windows-Server-2008-And-Speech-Recognition.html

      Now, I can see the Speech Recognition tab when I run “sapi.cpl”. I see all the options, but I cannot configure the speech engine nor can I train my profile. I’m stuck here.

      Scrnsht: http://img187.imageshack.us/img187/1567/speech.jpg

      Hope this helped! Please ask me for any more info that I can provide. 🙂 SOMEONE FIX THIS!! 😀

Viewing 3 reply threads
  • You must be logged in to reply to this topic.