Firefox 3 download problems in x64

Forums Operating Systems Windows Server 2008 Applications Compatibility Firefox 3 download problems in x64

Viewing 3 reply threads
  • Author
    Posts
    • #46819
      AvatarArris
      Moderator

      Never had this problem with Firefox. Maybe a clean installation of Firefox will help?

      1. Backup your bookmarks.
      2. Uninstall Firefox.
      3. Go to your Application Data folder by typing %appdata% in the address bar of Windows Explorer.
      4. Rename the Mozilla folder to something else (like Mozilla-bak).
      5. Browse one folder up to and open the Local folder: C:Users[username]AppDataLocal.
      6. Also rename the folder Mozilla to something else.
      7. Optionally you can also remove the Firefox registry keys: Open the Registry Editor (Start -> Run -> regedit) and navigate to HKEY_LOCAL_MACHINESOFTWARE (HKEY_LOCAL_MACHINESOFTWAREWow6432Node in x64) and rename all keys that start with Mozilla.
      8. Install the latest Firefox from http://www.getfirefox.com/.
      9. Restore your bookmarks.

      Hope that solves your download problem!

    • #46820

      The same the same thing happened to me in server 2003! x32 and x64. I hope that if this is a bug that they fix it. you may also want to report from a different OS or browser because the bug submission page crashes. Some parts did not render right. I had to use linux to submit it. I don’t know if it is my comp or not. No access to s03 to retest though. s08 should have much of the same since it is built on it but….

    • #46821

      The install of FF3 I have was a fresh install, I haven’t even restored my bookmarks yet. I will go ahead and send a bug in to Mozilla about this then and see if they have any solutions.

    • #46822

      I have installed FF3 on the same type of system and it worked for me. If it isn’t downloading to the downloads folder you can try changing the download location to something different by going to Tools->Options->Main and either changing where the files are downloaded or choosing “Always ask me where to save files”.

      Hope this helps 😀

    • #43236

      Ok, I installed Windows Server 2008 x64 and got all my drivers installed and the system working without many issues. I installed Firefox 3 and it runs, but whenever I try to download a file, FF3 says it downloaded it, but the files don’t exist where FF3 says they do. I have also tried just opening them from the internet, but the same thing happens. Has anyone else had this problem and know how to fix it

Viewing 3 reply threads
  • You must be logged in to reply to this topic.