External HDD Suddenly Stops Working (Well, Sort Of)………

Forums Operating Systems Windows Server 2008 R2 Hardware Compatibility External HDD Suddenly Stops Working (Well, Sort Of)………

Viewing 2 reply threads
  • Author
    Posts
    • #52195

      Any help???

    • #52196

      Try copying/accessing files on your external HDD on another physical computer to pinpoint if the problem is really software or hardware related. If it acts strangely no matter what computer you plug it into, all the policies/tweaks in the world can’t save you.

      Did you try changing the drive letter assignment on the external HDD in Computer Management?

      Try a different USB port possibly when you yanked out the cable accidently you damaged the port?

      If possible try a different cable for external HDD.

      When diagnosing hardware-related issues its best to eliminate as many obstructions as possible. For example if you have software that monitors the health of your disk like Acronis, you should disable it (and its services) in MSCONFIG. It could possibly be interfering.

      Also try changing the drive to “Optimize for performance” in Device Manager. Open Device Manager, navigate to Disk Drives, select your External HDD, click on Policy tab…and then change to “Optimize for performance” .

      Hopefully some of the above suggestions will lead you in right direction.

    • #52194

      The problem just got bigger. i tried using 2 freewares, Find and Mount, and TestDisk to recover the drive’s partition. when TestDisk was done it asked me to reboot. so i did. but now the drive doesnt even show in Disk Management or Computer. i didnt tell TD to format the drive, only to recover the partition. it made it bootable or something, i think. but theres no bootable info on the drive, only stored data files. And now i have no way of knowing if the data is even on the drive since it wont show up anywhere, on any computer that i’ve tried (2 so far). have also tried accessing it from the Live Linux USB key, it acts as if it’s trying to access the drive but after 10 mins of activity nothing shows up, but still shows me that it’s mounted. it wont let me view the drive contents, only that it’s mounted and about 60% full, which sounds about right since i had occupied a little less than 600 gigs of data on it. is this drive a goner, or this there a chance that i can at least recover the data before throwing the HDD away, short of taking it to a data recovery pro? i wont be storing anything else important on it even if i’m able to fix it, dont think i can trust it. in any case, i just got this drive from Target a few weeks ago. when he knocked the cord out i check the usb port to see if it was damaged, it doesnt seem to be, and all other devices plugged into that port operate fine. i even took it to a friend (the laptop) and he thoroughly tested the port with software and many devicesm, final conclusion is it’s not damaged. as for the hdd, nothing showed for him either, he says theres a 50/50 chance he can recover the large majority of the data at no cost to me, and also a chance that nothing will work. so i’ve left it with him for now. have also tried plugging the drive into the other ports, now nothing. and have also tried using a different cord, even though the old one doesnt look damaged. the hdd shows no external signs of damage and it didnt even move when the accident happened. any advice?

    • #44340

      ok, i’ll make this short, my friend accidently unplugged my external Western Digital 1TB HDD drive from my laptop while I was using it, as well as knocking out the power cord simultaneously. i dont recall actually using anything on the drive or transferring files to/from at the time this happened. But in any case, i plugged it back in and it just wouldnt let me read from it anymore in Computer. The drive’s icon was still there but wouldnt let me open it in either Explorer, Total Commander, or Directory Opus. Explorer froze up several times and i had to kill the process. and a few other apps i started attempted to access something on the drive and froze when they couldnt do so. I then removed the drive when Safe Eject failed to work. after plugging it back in the drive’s icon disapeared from Explorer entirely. I also noticed that the driver for the drive disappeared from Device Manager, whereas it was there before.

      I have tried plugging it into several other PCs, with varying results. In any case I can sometimes view the folders/files in this situation, and can sometimes open them. But at other times i cant. and even when i can the drive takes an unusually long time to respond.

      I have also tried booting into a Live Linux distribution from USB key and then plugging in the drive, and then attempting to copy them over to another external HDD that i also have plugged in. But the drive access is extremely slow and it often freezes up in the middle of trying to copy. This is unusual of Linux, as stable of an OS as it is, i often use it to fix problems that i cant fix in Windows, like virus/spyware/malware removal. this leads me to believe that the problem lies with the drive.

      I’m just trying to recover the files without having to format, as i have alot of important data on it i cant afford to lose. i basically want to copy over the data to another HDD so i can format it (after the fact) as NTFS, hopefully then it will work properly. Also, can i do a file scan check of some kind on the HDD? i know there is an option for that if i go to the drive’s properties, but i cant seem to access it from either my laptop or any other PC without Explorer crashing.

      Thanks for any help!

Viewing 2 reply threads
  • You must be logged in to reply to this topic.