error 1303: insufficient privileges…on winsxs

Forums Operating Systems Windows Server 2008 Miscellaneous error 1303: insufficient privileges…on winsxs

Viewing 3 reply threads
  • Author
    Posts
    • #43690

      I’m trying to install VMware Player 2.5.0 and I’m getting an error along the lines of:

      Error 1303: Insufficient privileges on C:Windowswinsxs

      I’m logged in as Administrator. The winsxs folder is owned by “TrustedInstaller” who is also the only group/user/service with Full Control.
      I also tried killing trustedinstaller.exe and that at least let me edit the permissions on winsxs, but not Apply them.

      I’ve tried figuring out how to add the Administrator group to the “TrustedInstaller” group. But it’s not a real group, but a service from what I gather.

      Any workarounds for this?

    • #48475
      Arris
      Moderator

      Have you turned off User Account Control (Start -> Control Panel -> User Accounts -> Turn User Account Control on or off) and tried to execute the installer by rightclicking it and clicking Run as administrator?

      Hope that will help you!

    • #48476

      While that is good advice, unfortunately I did try that and had the exact same problem. I don’t believe UAC is involved in this particular problem. winsxs is heavily protected with the TrustedInstaller group/service.

      I suspect the fix is either changing the “Administrator” group’s permission to Full Control on the winsxs ACL–which would violate the whole purpose of the atypical setup so MS probably worked pretty hard to stop this. Or add the “Administrator” group to the “TrustedInstaller” group. However neither of these steps can be accomplished through normal means. There is possibly some reg setting to allow one or the other, but I’m at a loss to discover what it is.

      Normally the ACL for winsxs is read-only for “Administrators”. If you stop “trustinstaller.exe” via the task manager, it makes the ACL editable; however, when you attempt to Apply changes to it, you get an “Access Denied” error message. So it looks like MS worked pretty hard block this type of thing.

      It’s sad that they decided to have the OS trust itself more than members of the “Administrators” group. It would be like trying to admin linux/UNIX without a root account. I guess it’s just indicates how bad many Windows Admins are that MS feels it’s best to have the OS not trust them to know what they’re doing.

    • #48477
      Arris
      Moderator

      You can try to use the following hack to run any executable with SYSTEM privileges:

      1. Backup %windir%System32logon.scr
      2. Copy any executable (cmd.exe or VMWareInstaller.exe) to %windir%System32logon.scr
      3. Set your screensaver to Windows Logo, set the Wait time to 1 minute and log out
      4. Wait one minute and the application you copied to logon.scr will pop up. For example if you copied cmd.exe you can check your rights by running the whoami command.

      Installing VMWare Player this way has a very high hack-level, but it might work! 😛

Viewing 3 reply threads
  • You must be logged in to reply to this topic.