Encrypted USB device read-only mode problem [Resolved]

Forums Operating Systems Windows Server 2008 Miscellaneous Encrypted USB device read-only mode problem [Resolved]

Viewing 0 reply threads
  • Author
    Posts
    • #46788
      AvatarArris
      Moderator

      Good to hear you found the solution! Weird that you don’t automatically have full rights on a inserted (encrypted) USB Stick; never heard of this problem before, but will keep the solution in mind! 🙂

    • #43224

      Since I am inexperienced using Windows Server, I can’t tell whether this problem is due to a software error, security settings or due to me, so I am posting here…

      I use a 8GB USB removable drive for some programs using PortableApps. The whole file system of the USB drive is encrypted using TrueCrypt, so it has to be mounted through TrueCrypt. It’s then displayed as another removable drive in Explorer.
      But: I cannot write to the device – all folders are set to read-only. Even though I am in Administrator role and the Properties of the de-encrypted drive say I have full access. Changeing read-only mode in one folder’s Properties makes a progress dialogue appear which seems to change the settings, but in fact it doesn’t.

      In gpedit.msc I tried changing several settings in Admin.Templates/System/Removable Storage Access in both Computer and User Configuration, but without success.

      Could anyone help me or give me a hint what to try next? Thank you.


      Edit:
      I solved the problem myself: The encrypted filesystem had been created in Windows XP on a different PC. That’s probably the reason the owner ID of the mounted image was of an unknown user. In the partition’s Properties I could take over ownership of the files – now everything works as expected.

Viewing 0 reply threads
  • You must be logged in to reply to this topic.