DVD Shrink installs but won’t run

Forums Operating Systems Windows Server 2008 R2 Applications Compatibility DVD Shrink installs but won’t run

Viewing 1 reply thread
  • Author
    Posts
    • #52125

      Hello Steve,

      This is Steve as well haha. The solution is simple. All you need to do is simply disable DEP on the DVD Shrink application.

      If you are unsure how to do this I have provided step-by-step instructions with screenshots below:

      (BTW this is not Windows 7 I have just skinned it to resemble it by replacing the Basebrd.dll file with one from my 64-bit Windows 7 laptop).

      Step 1: Right-click on Computer and choose Properties

      Step 2: Click on Advanced System Settings

      Step 3: Click on Settings… button underneath performance

      Step 4: Click on the Data Execution Prevention tab

      Step 5: Click Add…

      Step 6: Navigate to C:Program Files (x86)DVD Shrink and choose the DVD Shrink application.

      Step 7: Click on apply in the performance options window and then OK to close it ok. Exit out of everything now.

      Step 8: Now launch the DVD Shrink utility, accept the license agreement to continue and the program should now load as indicated below.

      This solution process works for quite a few applications that run fine in 7 but not in R2. Try this technique if you ever receive any “application has quit” messages. It doesn’t work for all apps, but this is usually the first thing I try before using more dirtier methods.

    • #52126

      Steve,

      Many thanks. Worked perfectly. The problem for me was that I just assumed that setting the compatibility setting to XP SP3 would set an exception for DEP. I never checked to make sure that it had.

      Now I know that it doesn’t, and your very thorough post will probably help someone else eventually.

    • #44310

      Hello, I’m just getting started with Server 2008 R2 installed to a new build. The OS is from the Dreamspark website. Many thanks to all who have contributed to this website.

      The title of my post tells the story. As soon as I start DVD Shrink, I get a box telling me that the program has quit. The OS offers to try troubleshooting. After I choose the selection for a program that ran on a prior OS, I’m offered various compatibility settings. The ones I’ve tried are XP SP2 and XP SP3. Both of those fail in the same manner.

      The install file that I downloaded from MajorGeeks isn’t corrupted. It installs and runs just fine on my Win 7 Professional 64 bit laptop. This seems strange to me, as I thought that Win 7 64 bit and R2 shared the same Windows on Windows software.

      A few thoughts:

      (1) I haven’t installed any of the game related files that are discussed on the main page. Is there any possibility that these files are required for programs other than games?

      (2) One of my reasons for trying out Server 2008 R2 was to get some experience with Hyper-V. I can download the Microsoft XP VHD from Microsoft since I own Win 7 Professional. Could I get around the problem by running DVD Shrink on virtualized XP? If it matters, my Sandy Bridge Pentium supports Vt-X but not Vt-D.

      Thanks in advance.

Viewing 1 reply thread
  • You must be logged in to reply to this topic.