Dirt 3 – Semi-working

Forums Operating Systems Windows Server 2008 R2 Games Compatibility Dirt 3 – Semi-working

Viewing 0 reply threads
  • Author
    • #44373

      I added this to the compatibility list thread but thought I would make a separate topic in case anyone has any other issues with this game.

      Upon launching the game, 2008 R2 will kick back an error about DSS Launcher and an appcrash. To fix this and keep it from crashing upon launch, you must disable SEHOP –

      Disable SEHOP:

      open / run regedit
      Go to: HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlSession Managerkernel
      delete the following - DisableExceptionChainValidation and DistributeTimers

      Once the game launches, it may crash upon starting a race. If so, change audio setting from Rapture3D to software in the games settings.

      Found out about the Rapture audio crash issue on another forum. I’m not sure if it’s specifically related to Realtek sound or if it’s global.

      Not sure if DEP must be off or not. I disabled it long ago, so I don’t know if having it on would make a difference. If you still have problems, disable DEP:

      To disable DEP: open an elevated Command Prompt by right clicking on it and running it as administrator. Type the following:

      bcdedit /set nx AlwaysOff

      I had no problem installing Dirt 3 or any problems with GFWL. But I use an offline profile.

      Thanks to Allukend for the SEHOP fix from the Fable 3 thread.

      DISCLAIMER: I will not be held liable, or responsible, for you mucking up your computer by editing the registry. By doing this, you do so at your own risk. Always backup your registry before making changes.

Viewing 0 reply threads
  • You must be logged in to reply to this topic.