Ati 8.11 and 8.12beta crash during installation

Forums Operating Systems Windows Server 2008 Hardware Compatibility (New) Ati 8.11 and 8.12beta crash during installation

Viewing 4 reply threads
  • Author
    Posts
    • #47797
      AvatarZiG
    • #47798

      yes

    • #47795

      Maybe its because my windows is in notification period?
      I downloaded 8.12 final and its the same thing, even my old 8.8 installation does not work, so its definitely not a problem with drivers, only thing i can think of that has changed is that windows entered notification period.

      I (stupidly) deleted all ati drivers and software to see if that would help and it didn’t. Now i have generic driver 😀
      Manually from device manager it seems like its installed but after restart its not installed and in device manager it says: “Windows has stopped this device because it has reported problems. (Code 43)”.

      This is from event viewer:
      “Faulting application InstallManagerApp.exe, version 3.0.704.0, time stamp 0x4934447b, faulting module MFC80U.DLL, version 8.0.50727.1833, time stamp 0x482bb4a2, exception code 0xc0000005, fault offset 0x00000000000854ee, process id 0xdf4, application start time 0x01c95b245e3b0ac1.”
      Found couple of reports in AMD forums but no solution:
      http://forums.amd.com/game/messageview.cfm?catid=279&threadid=95541&enterthread=y
      http://forums.amd.com/game/messageview.cfm?catid=279&threadid=103026&enterthread=y

    • #47796

      From ATIs InstallManagerApp.RPT:

      Exception code: C0000005 ACCESS_VIOLATION
      Fault address: 735A54EE 01:000844EE C:WindowsWinSxSamd64_microsoft.vc80.mfc_1fc8b3b9a1e18e3b_8.0.50727.1833_none_8442d417329336b1MFC80U.DLL

      After many hours of searching i found out that i should avoid mfc dlls version 8.0.50727.1833 (that was most likely installed by sql server 2008).
      Adobe had same problem with their installer and found a solution:

      Fix: Installing the attached vcredist_x86.exe will install a new version (8.0.50727.3079) of the Microsoft redistributable DLLs including mfc80u.dll to resolve this issue

      http://www.adobe.com/support/products/enterprise/support_knowledge_center_livecycle_ES_server.html
      …but it is only for x86 applications and i needed x64. I tried to find vcredist_x64.exe version 8.0.50727.3079 but had no luck with that (downloaded 4 different redistributable packages), it seems that ms is still testing that version and it is not available to everyone. Then i searched some more on internet and found a way to change dll bindings from older to newer versions and also deleted MFC80U.DLL v8.0.50727.1833, after that installer is not crashing anymore (hooray!) but i still cant install driver properly.

      From device manager: “Windows has stopped this device because it has reported problems. (Code 43)”. And i’m so tired (and angry) from all this that i dont know what more i could try…
      I restarted my pc like 1000000 times, tried all kind of stuff including removing and changing moemory sticks. Also tried Driver Cleaner and there is no difference.
      It seems that it would have been more easier to just install windows from scratch 😥

    • #47799

      Finally an official fix from microsoft, for 32bit and 64bit versions. Visual C++ 2005 redistributable version 8.0.50727.3079.

      Info: FIX: An application that uses the Mfc80.dll module or the Mfc80u.dll module crashes after you install a product that updates the module version
      Download: http://code.msdn.microsoft.com/KB961894/Release/ProjectReleases.aspx?ReleaseId=2067

      That’s for installer crash problem.



      And also other problem is fixed with latest 9.1 drivers.

      Resolved Issues for the Windows Vista Operating System
      This section provides information on resolved issues in this release of the ATI
      Catalyst™ Software Suite for Windows Vista. These include:
      With some ATI Radeon adapters and Windows Vista 64 systems with more
      than 4 GB of system memory the display driver may fail to load and report a
      code 43 error

      …………..

      from release notes: https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/gamesite/Catalyst_91_release_notes.pdf

    • #43501

      I downloaded latest 8.11 drivers from ATI and after unpacking it shows welcome screen, i click next, chose install (or uninstall) and it crashes. Same thing happens with latest 8.12 beta drivers. But i wouldn’t say that drivers are the problem, it looks like installer is crashing at beginning.

      Anyone had this kind of problem?

      I currently have 8.8 drivers installed, i’ll try to find 8.10 or 8.9 maybe one of them will work.

Viewing 4 reply threads
  • You must be logged in to reply to this topic.