Re: Re: Themes in Remote Desktop

Forums Operating Systems Windows Server 2008 Wish List Progress Themes in Remote Desktop Re: Re: Themes in Remote Desktop


Thanks everyone for the pointers. I wanted the same results but was not happy with patching system files etc.

So I thought that if the creation of the Remote subkey in the registry is the reason why Vista theme cannot be selected, then just Deny the user the permission to create the subkey. I tried the theory and it worked!!!!! 😀

Steps are:
1. Login as the user for which you want to enable the Vista theme (this can by direct login or RDP login)
2. Open registry and goto key HKCUSoftwareMicrosoftWindowsCurrentVersionThemeManager
2b. If you logged in via RDP then Delete the Remote subkey at this point
3. Right click the ThemeManager key and select Permissions… from the context menu
4. Select the user and click the Advanced button to edit permissions
5. Select the user and click the Edit button to change the permissions
6. Select the Create subkeys Deny checkbox. Leave others checkboxes empty. On pressing OK you’d get a warning but click Yes.
7. Change to Vista Theme (if you hadn’t already). Logoff and RDP back in.
8. That’s all.


And thanks again for giving me the idea.